account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

wifi authentication problem

One time poster
Message 31 of 50
5,152 Views
Message 31 of 50

Re: wifi authentication problem

Virginmedia router, plus samsung tablet, worked for me
One time poster
Message 32 of 50
5,122 Views
Message 32 of 50

Re: wifi authentication problem

Hi,

 

I had same problem - it just dropped out. it would momentarily authentic and state 'secured and saved' but then not connect.

I played around a bit and finally I am back on - here is how i did it:

 

1.  Turn your phone off

2. Instead of just pressing the on and off button to turn it back on - you need to REBOOT it (the following reboot instructions also work for when your screen blacks out and the phone 'dies' and wont turn on)

 

To re-boot you press with your finger the on/off button and keep it down while - with the other hand - you rock the volume button up and down about 4-5 times.

 

The Sony sound will appen and the sony icon will pop up and then it will reboot and start as normal.

 

3. Once you have rebooted the pone - go to your own wireless box.  Simply  switch it off and wait for a minute before tunring it back on.

 

 

4. Once you have turned it back on - go into your phone under 'Settings'.

 

5. Under the tab 'Personal' you will see 'location / security / language & input / back up and reset / and set up guide.

 

6. Select 'Set up guide'.

 

7. The set up guide has 7 steps (these are easy dont worry) 

       step 1 - agree to info (tick accept)

       step 2 - it asks how you want to connect with internet and this should already be selected for you depending on

                    your data plan so dont change anything on here just press the ---> arrow to go to next page

       step 3 - time and date (self explanatory) you have probably already done this when you first got phone

       step 4 - Wifi connection    (this is the one you want) ...

 

Under Wifi connection  select 'search networks'.

When you select it yours should automatically appear on the top and it will automatically start ''authenticating''.

 

Now HERE IS THE THING.

 

Keep your eyes on it because - you have to press the 'DONE'  button very quickly as soon as it says 'saved / secured'.

 

If you dont do it quickly you will get the authentication issues again.  If you are not fast enough, dont panic, just select your

wifi  name again, and select ''connect'' - as soon as it connects again and states 'saved' press the 'done' or 'next' button quickly.

 

You then press next (  ---->   ) on the last two screens and dont forget to press 'finish' on the last screen.

 

Go to your internet page and see if it works.

 

 

I have done this two or three times now and it does work - but who knows - could just be my phone ?

 

Let me know if this works for you guys too :-)

One time poster
Message 33 of 50
4,923 Views
Message 33 of 50

Re: wifi authentication problem

I've got a Xperia M2, I literally just got it back from repair on Friday. Friday night, I set it all up and the wifi was working fine, when I woke up the wifi had turned off so I tried connecting it and it said "authentication problem", which doesn't make sense because all the other devices that are connected to it work fine with the wifi. How do I solve this? Or should I just send it back to repair?

I'm starting to give up with this phone as it has been sent into repair 4 times since I got it just over a year ago...

Please help!

Genius
Message 34 of 50
4,920 Views
Message 34 of 50

Re: wifi authentication problem

Hi @Alison98

 

Please, read the information here that could be useful for you. Also try change security option on your router from WPA-PSK to WPA/WPA2-PSK, or install WIFI Optimizer from Play Store that will indicate the recommended for best performance channel! on your WIFI network. I´m at disposal for any question.

"We can have anything we want on life, if we just help others to found what they need” - Ebelsain Villegas
One time poster
Message 35 of 50
4,754 Views
Message 35 of 50

Re: wifi authentication problem

Hi,

I own the Z1 and i too have the same problem. I have a open network in my college which is not possible for router configuration. please suggest the possible diagnosis from the mobile end only. i cannot have my hands or control over the router. It is to mention that even the dead cheap andro mobiles are able to connect and access internet through this open access, but im not able to do that. This is very embarrasing and sony is going down if they dont care about thier customers like this.

 

hoping for the best solutions from sony team.

One time poster
Message 36 of 50
4,426 Views
Message 36 of 50

Re: wifi authentication problem

On your phone Go to Maccafe mobile security

turn off the wifi security

restart

One time poster
Message 37 of 50
4,393 Views
Message 37 of 50

Re: wifi authentication problem

I got this problem yesterday. Let your phone forget the netword and connect again.

One time poster
Message 38 of 50
4,315 Views
Message 38 of 50

Re: wifi authentication problem

hello my mobile xperia z2 is not connecting o my wifi although my laptop is connecting with it properly and i also reset my mobile due to which lost all data but still not connecting please help me out guys because it takes alot of charges using mobile data. the problem is i turned it on and it gets off automatically just after i take off my finger from the screen of mobile.

One time poster
Message 39 of 50
4,235 Views
Message 39 of 50

Re: wifi authentication problem

I have the same problem, with both my old phone and my new phone. Both are Xperia, but the new one is an Xperia M4 Aqua.

 

I can connect to the network manually, but I always get the Authentication problem anyway. This happens when I connect to any of the networks that I usually use, like the one in McDonald's, for example, not just at home. My other devices connect to WiFi just fine. So I know that it's my phone.

 

Your help will be greatly appreciated. I've used up 90% of my data allowance because of this problem.

 

Sincerely,

 

cindybubbles

One time poster
Message 40 of 50
3,748 Views
Message 40 of 50

Re: wifi authentication problem

Got it working finally by going to advanced WIFI settings, pressed the WPS push button, then did a wifi router restart at the same time, got my home wifi working on my phone and its still working on all other devices.