account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

No sound from phone after removing earphones

SOLVED
Adept
Message 1 of 24
10,249 Views
Message 1 of 24

No sound from phone after removing earphones

Hi, after installing 4.4, whenever I remove the earphones from my ZU, the speakers will stop producing sound, as though it detects that the earphones are still plugged in. In order to fix this, I have to restart my phone and refrain from plugging in earphones.

 

And yes, I have performed a repair using SUS, and still yields the same results.

 

Any solution for this?

 

I'm currently running on firmware 757

1 ACCEPTED SOLUTION

Accepted Solutions
Adept
Message 19 of 24
10,420 Views
Message 19 of 24

Re: No sound from phone after removing earphones

Yeah, did a little research and apparently, the earphone issue is what caused the sound bug.

 

Basically, after you unplug the phone from the device, the phone still thinks the earphone is still plugged in. Hence, it tries to project sound through a ''earphone'' instead of the speakers.

 

I downloaded the app SoundAbout on my ZU and temporarily fixed the bug. Basically, it forces the phone to use the speakers instead of the earphones.

23 REPLIES 23
Moderator
Message 2 of 24
10,246 Views
Message 2 of 24

Re: No sound from phone after removing earphones

Try to do the same procedure for some time,play music or while in a call remove the earphones.



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.

Adept
Message 3 of 24
10,244 Views
Message 3 of 24

Re: No sound from phone after removing earphones

Just tried it, the moment I removed the earphone while in a call, there was no sound from the speakers.

 

Moderator
Message 4 of 24
10,239 Views
Message 4 of 24

Re: No sound from phone after removing earphones

Try settings-apps-all-smart connect,force stop and clear data.See if that helps.



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.

Adept
Message 5 of 24
10,237 Views
Message 5 of 24

Re: No sound from phone after removing earphones

Doesn't work, also tried disabling the smartconnect itself.

Moderator
Message 6 of 24
10,229 Views
Message 6 of 24

Re: No sound from phone after removing earphones

Very strange,retry the procedure with removing the earphones several times.



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.

Adept
Message 7 of 24
10,224 Views
Message 7 of 24

Re: No sound from phone after removing earphones

Plugged and unplugged my earphones several times, doesn't work too. Is it just me or the 757 firmware is impotent?

Moderator
Message 8 of 24
10,214 Views
Message 8 of 24

Re: No sound from phone after removing earphones

I do not have this issue and I am on 757 on Z1.



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.

Adept
Message 9 of 24
10,213 Views
Message 9 of 24

Re: No sound from phone after removing earphones

Heck, I'll just perform a repair again.

Moderator
Message 10 of 24
10,211 Views
Message 10 of 24

Re: No sound from phone after removing earphones

Try it with SUS.



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.