account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

MHL issue with lollipop 5.1.1

Learner
Message 1 of 7
3,110 Views
Message 1 of 7

MHL issue with lollipop 5.1.1

hello,

In 5.1.1 for my xperia z ultra , the mhl connexion doesn't work any more.

I try with my tablet xperia Z4 in 5.0.2 and it works.

i try to reset my phone with sony companion and the issue is the same.

 

any help will be appreciate.

 

best regards

jean marc

6 REPLIES 6
Forum Legend
Message 2 of 7
3,095 Views
Message 2 of 7

Re: MHL issue with lollipop 5.1.1

Hi,

Could you please elaborate? How do you mean that the connection does not work any more? What kind of MHL adapter are you using?

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Learner
Message 3 of 7
3,090 Views
Message 3 of 7

Re: MHL issue with lollipop 5.1.1

hello,
i use the Mondpalast adapter
http://www.amazon.fr/gp/product/B00QEKEFE2.

i connect the sony xperia z ultra to my sony lcd 46X3500 on HDMI3.
i connect the usb cable to the output 46X3500 usb .

i have the mhl icon on my xperia,but i have no image on my tv.
the mhl icon disappears after few seconds and reappears again and disappears etc...


jean marc

Forum Legend
Message 4 of 7
3,083 Views
Message 4 of 7

Re: MHL issue with lollipop 5.1.1

I have tried with our MHL to HDMI Adapter IM750 and it works fine for Xperia Z Ultra with 5.1.1. Since this is a third party adapter, it's hard for me to guarantee full compatibility with our products. I suggest that you check if you can try your Z Ultra with our IM750 or a TV that supports MHL to see if it works, just to exclude problems related to your phone.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Learner
Message 5 of 7
3,068 Views
Message 5 of 7

Re: MHL issue with lollipop 5.1.1

I try with sony hmz-t3w and my mondpalast mhl adapter, i have the mhl icon and the icon appears

appears continuously 

But i have no image. 

I try the same with success with the xperia tablet z4.

The adapter IM750 doesnt seem to be sold anymore. 

Message 6 of 7
2,851 Views
Message 6 of 7

Re: MHL issue with lollipop 5.1.1

I HATE YOU SONY!!!!!

 

 

You ruined all of my Z ultras for my car visor project!!

 

your 5.1.1 killed the MHL function on my 3rd party adapter.

 

either start selling the IM-750 again, or fix what you broke!

 

EVEVRYTHING I OWN IS SONY! and will burn it on you tube if you dont fix this! 

 

 

Highlighted
One time poster
Message 7 of 7
2,412 Views
Message 7 of 7

Re: MHL issue with lollipop 5.1.1

I have the exact same problem on my Sony Xperia zl. Mhl worked flawlessly before the upgrade to Android 5.1.1 

Now I can only see that Mhl detected on the mobile but nothing on the TV. The same mhl cable works fine with another Sony Xperia z ultra which is running on older Android version.

Can you help me make this mhl work.

Note: there is no problem with the mhl cable, I used it before as well with no issues.