account arrowhead-down arrowhead-up cart mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Mobile World Congress 2019

Sonys Press conference from MWC took place end of February
If you missed it you can watch it here.
Please join the discussion here and share your thoughts on what was anounced here. MWC 2019 discussion.

Wifi connectivity issues

Highlighted
Learner
Message 1 of 12
1,185 Views
Message 1 of 12

Wifi connectivity issues

I have a problem where my XZ3's WiFi can no longer connect to the internet. WiFi stays on, it says it's connected to the network, but no internet (I haven't tried local network connectivity). By turning WiFi off and on, the issue is resolved, and it happens on all WiFi connections I make. It occurs after at least an hour, sometimes much longer, but no clear pattern.

I searched the forums, and found a post describing this issue, from 2015 and 2017, with no useful solution, other than to turn WiFi off and back on...

 

Does anyone else have this problem?

11 REPLIES 11
Pioneer
Message 2 of 12
1,163 Views
Message 2 of 12

Re: Wifi connectivity issues

You did follow the suggestions from the manual?


who knows knows
who doesn't doesn't
Learner
Message 3 of 12
1,102 Views
Message 3 of 12

Re: Wifi connectivity issues

I can check the ip address assignment on my home router, since it uses static ips, but other than that (and factory reset) the other options either don't apply, or don't help.

The issue is not with the signal dropping, since I will still have full bars on my phone. It simply loses the internet connection. This happens on all wifi networks I connect to for a longer period of time. My home networks is 2.4ghz, and my work network is 5ghz.

On Android 9 I can't find a setting for 'Keep wifi on during sleep', has this setting changed?

Talent
Message 4 of 12
1,033 Views
Message 4 of 12

Re: Wifi connectivity issues

I am experiencing similar issues. And for what it's worth, I had the EXACT same issues with my XZ Premium before this. Eventually Sony released an update for the XZ Premium that solved the issue (45.0.A.7.137). I wouldn't be surprised if that 'wifi fix' was omitted from this device.

 

I'll open a seperate topic about this.

Talent
Message 5 of 12
968 Views
Message 5 of 12

WiFi problems (no connectivity / unable to connect)

New phone, new WiFi problem I guess. Phone more than occasionally loses WiFi and doesn't connect to the internet. Or simply that it won't connect at all. Usually it's the first.

I see that the phone recognizes this and tries to 'switch' the WiFi on and off. This works, sometimes. Most of the time it doesn't however.

 

For now I'm burning through my 4G data.

 

But hey, guess what? I had the EXACT same problem with my XZ Premium. The issue is widely spoken about in thread https://talk.sonymobile.com/t5/Xperia-XZ-Premium/Wifi-signal-dropping/td-p/1229275

 

Now, what fixed my problem was update 45.0.A.7.137. So whatever you guys fixed in 45.0.A.7.137 needs to be implemented in the Android 9 update for XZ3 too.

I understand that it's extremely unlikely that an actual Developer will look at these forums (you should really, I mean, really...) but it's worth a shot still.

 

I also contacted Sony NL Support. But they're 'helpfull' in their own ways, to say it nicely.

 

Hope this gets sorted out soon. I hate to sit for 5 months again on 4G.

 

Thanks.

Visitor
Message 6 of 12
976 Views
Message 6 of 12

Pie 9 breaks wifi

Can anyone help .I have an issue when on WiFi nothing loads, no netflix amazon etc  I Googled the issue and it points towards pie 9 being the cause but all the info I find is on pixel forums. Is this a known issue with the xz3 or do I have a faulty device?? 

Visitor
Message 7 of 12
974 Views
Message 7 of 12

Re: Pie 9 breaks wifi

I'll add an edit. This is an issue with this phone all others work in the house on wifi. I've tried on multiple other WiFi networks same issue. Just bought the phone 2 days ago and it's ever worked on wifi  It's also fully updated. 

Pioneer
Message 8 of 12
905 Views
Message 8 of 12

Re: Pie 9 breaks wifi

Do you experience the same behaviour in safe mode?

In safe mode the device runs without added apps.

 

What happens when you doa software repair using Xperia Companion?

To be sure nothing interferes after software repair don't restore your backup to start with.

 

Hope you can finda way out.

 


who knows knows
who doesn't doesn't
Moderator
Message 9 of 12
836 Views
Message 9 of 12

Re: Pie 9 breaks wifi

Hi guys, 

I'll keep my eye out for this one as I remember it well from xz premium.

As of yet, I've not had it happen, I don't know if that's because I'm solely using 5ghz?

I'll join the 2.4 at work and at home use both and see if I can get this triggered.



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views.
Click here to find out more about the different roles on the community.

One time poster
Message 10 of 12
630 Views
Message 10 of 12

Re: Pie 9 breaks wifi

2 brand new phones setup yesterday and mine won't stay on wifi, 30 seconds max so everytime I click on something I have to retry.

I've reset routerand turned wifi disks off, /there was noway I could get it on the 5hz network till today.

 

So looks like mines going back, any advice pls.