account arrowhead-down arrowhead-up cart mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Mobile World Congress 2019

Sonys Press conference from MWC took place end of February
If you missed it you can watch it here.
Please join the discussion here and share your thoughts on what was anounced here. MWC 2019 discussion.

Moisture detected in usb slot xperia xz2

Learner
Message 1 of 15
3,519 Views
Message 1 of 15

Moisture detected in usb slot xperia xz2

Phone has not been near water yet tells me moisture has been detected then pauses my music. Ideas? Thank you in advance 

 

14 REPLIES 14
Emperor
Message 2 of 15
3,516 Views
Message 2 of 15

Re: Moisture detected in usb slot xperia xz2

@Meshach

 

I don't have this particular Xperia but how does it notify you about the moisture ?




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Learner
Message 3 of 15
3,502 Views
Message 3 of 15

Re: " Moisture detected in usb slot" xperia xz2

Moisture in the cable connector when you connected to the phone. Or external moisture on the phone when ypu connected.

Blow the connectors dry and try again!

Learner
Message 4 of 15
3,448 Views
Message 4 of 15

Re: " Moisture detected in usb slot" xperia xz2

I also consistently receive this message without any evidence or indication of moisture. 

 

Also I sometimes plug in to charge and the phone says it is providing power to external device. Which makes zero sense when connecting a charger. 

Learner
Message 5 of 15
3,443 Views
Message 5 of 15

Re: " Moisture detected in usb slot" xperia xz2

Just a pop up message saying what I put in quotation marksmarksmarksmarks, really annoying

 

Message 6 of 15
3,421 Views
Message 6 of 15

Re: " Moisture detected in usb slot" xperia xz2

Same problem here. My phone nor headphone dongle wasn't near any water source. The port isn't recognizing I think.  Cannot even hear music. What's the use of spending lots of money.? I request xperia team to look into this issue immediately. 

One time poster
Message 7 of 15
3,382 Views
Message 7 of 15

Re: " Moisture detected in usb slot" xperia xz2

A system app named something like usbsettings had to be wiped clean of its data on a Samsung S8 when it falsely claimed to be wet. After a reboot it worked. Maybe Sony has a similar USB monitoring app? Can't verify myself since I haven't gotten my Sony phone yet. 

Message 8 of 15
3,350 Views
Message 8 of 15

Re: " Moisture detected in usb slot" xperia xz2

@swejuggalo there's a system app called USB connectivity that sends that message on Sony phones. 

One time poster
Message 9 of 15
3,286 Views
Message 9 of 15

Re: " Moisture detected in usb slot" xperia xz2

This problem started for me a few days ago. It was saying moisture in USB when headphones were plugged in but was fine when charger was plugged in. I spoke to support and they suggested repairing my software. This did absolutely nothing other than make me lose some data because the backup apparently doesn't capture everything. Being ex-IT support myself the information told me it's probably an issue with the adapter itself and not the phone so I bought a new adapter off of amazon for a few £ and it's working absolutely fine. The old adapter (the one I received from Sony) is still saying moisture so I think it's definitely the adapter. I hope this helps. 

Message 10 of 15
3,274 Views
Message 10 of 15

Re: " Moisture detected in usb slot" xperia xz2

Thanks a lot !!!! Even I feel that that is the problem as the charger is working fine. I will replace the adapter soon. Guess this was a problem for all sony xz2 users who arer using the headphone dongle from Sony. Maybe a manufacturing defect I think, as I saw a lot of people asking the same question in the internet. Thanks a lot!!!! You just saved my life.