account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

Google Smart Lock - Xperia XZ2

Rookie
Message 1 of 13
3,559 Views
Message 1 of 13

Google Smart Lock - Xperia XZ2

I've seen similer posts on this issue on other phone versions and it seems it might be common to Andriod 8.0. However, I wanted to start a thread under the Xperia XZ2 category to see if anyone might have a fix for this? I just recevied my XZ2 and I love it! I set up smart lock, but after awhile it seems to not work and when I go into the settings to see whats wrong, the page is just blank. I have also tried turning this feature on and off again from the settings, but that gets annoying having to do that all the time. Does anyone know if Google has a fix coming for this? 

12 REPLIES 12
Highlighted
Adviser
Message 2 of 13
3,502 Views
Message 2 of 13

Re: Google Smart Lock - Xperia XZ2

I don't think that it is a general Android 8 Oreo issue. The problem only exists with those phones that were originally delivered with Android 8, such as our XZ1 and XZ1 compact.

Older phones, like our XZ and X Compact, that have received Oreo as an software update, don't have the problem, Smart Lock is working perfectly fine with these devices, even after restarts.

The April Update should be around the corner, my XZ received it already yesterday, waiting for the newer devices. It is a little shame though that even the XZ2 still has this problem...

Learner
Message 3 of 13
3,329 Views
Message 3 of 13

Re: Google Smart Lock - Xperia XZ2

Same issue. got an Xz2 out of the box and smart lock settings screen is just blank. Frustrating in the car. 

Message 4 of 13
3,210 Views
Message 4 of 13

Re: Google Smart Lock - Xperia XZ2

Still no fix for the broken SMART LOCK feature, not even with the latest firmware which arrived today.
It's becoming frustrating, having the same serious bug since Oreo was introduced.

It was annoying on the XZ1 and it's even more annoying on the XZ2 because it shows that Sony doesn't listen or care at all.

One time poster
Message 5 of 13
3,097 Views
Message 5 of 13

Re: Google Smart Lock - Xperia XZ2

My smart lock dit work before I had a latest software update, but I so now I have the same problem, but I dit not find a solution for is. 

One time poster
Message 6 of 13
2,965 Views
Message 6 of 13

Re: Google Smart Lock - Xperia XZ2

Disable Smart Lock in Settings - Trusted Agents.

Reboot.

Enable Smart Lock.

Seems to be a generic issue, not Sony's fault.

https://talk.sonymobile.com/t5/Xperia-XZ2-Compact/Google-Smart-Lock-does-not-work/td-p/1315676

Message 7 of 13
2,808 Views
Message 7 of 13

Re: Google Smart Lock - Xperia XZ2

Just wanted to say that, with the latest firmware, the issue seems to be fixed. Just rebooted and the Smart Lock ist still active 😊

Message 8 of 13
2,406 Views
Message 8 of 13

Re: Google Smart Lock - Xperia XZ2

AAAAAAND they managed to make things worse again.

Received the latest September Firmware today and Smart Lock is broken again.

Regular
Message 9 of 13
2,369 Views
Message 9 of 13

Re: Google Smart Lock - Xperia XZ2

I have the same issue. It was working before this month's update. Looks like they broke it. My is US version (H8266).

Learner
Message 10 of 13
2,364 Views
Message 10 of 13

Re: Google Smart Lock - Xperia XZ2

Do a reboot and try again. Sometimes i needs to do more than one reboot to make it work.