account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Display problem

Sony Xperia Support
Message 11 of 18
313 Views
Message 11 of 18

Re: Display problem

Hi again @Dark-Orchid and thank you so much for the pictures!

I have to agree with @GANGSTAR here, it does look like a defect screen, however just to make sure that it's not related to the software in the device, I would recommend that you perform a software repair using Xperia Companion, as this will reinstall the latest available software in the device.

Do note that in the same process, all data stored on the internal storage will be deleted, so it's important that create a backup using the same program, before you start with the repair.

 

If the line is already showing in the start-up guide after the software repair has been finished and you have powered on the device, get in touch with your Local support team and they will assist you further with having the device sent in to an authorized service centre.

Feel free to keep us posted on how it went!


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Highlighted
Rookie
Message 12 of 18
296 Views
Message 12 of 18

Re: Display problem Photos of screen

Hi,

Thank you for your response. The problem has been resolved and I have no idea how or why! I'd switched off the phone and restarted it, messed about with display settings, switched it off for the night and restarted in the morning and it was exactly the same. Then I glanced at my phone at around midday three days ago and the line had gone. I've switched my phone on and off etc. to see if the line had returned and left it a couple of days just in case and, so far, it's not reappeared - it's bizarre. I'd like to thank you for looking at the problem for me. The forum has been really useful as it has answered my queries about what it could be, possible solutions and the fact that my phone supplier is blatantly wrong in saying that it's out of warranty. So many thanks for your help and advice. It's much appreciated.

Regards

Simon

Rookie
Message 13 of 18
295 Views
Message 13 of 18

Re: Display problem

Hi,

Thank you, Jonas. As I've mentioned in reply to @Gangstar, the problem has disappeared (hopefully). Thank you for your advice especially the software repair option which I had never heard off. Advice like that is gold dust for amateurs such as I. I did make me think whether an update had caused or solved the problem but my tech knowledge of phones is as poor as my photography skills! Again thank you for your help, it is really appreciated

Regards

Simon

Sony Xperia Support
Message 14 of 18
291 Views
Message 14 of 18

Re: Display problem Photos of screen

Hi again @Dark-Orchid and that is awesome news!

I do really wish that I could tell you exactly what fixed it, but as far as I know the only setting in the device that can produce such a line can be found in the Developer options.

Hopefully the line won't show up again and if it does and it does not help to turn it off and mess around a bit with the settings, you have all the needed troubleshooting in this thread.

To be honest with you, neither retailer or the manufacturer should never say that the device is out of warranty (if it's still in the 2 year warranty period) before the device has been examined at an authorized service centre, as it's the technician that examines the device that makes this decision, based on the warranty terms and so forth. I do understand that it's frustrating when you seek help and they reply with "this is not covered by the warranty", when they don't really have the support for the device.

Feel free to let me know if there is anything else I can assist you with and thanks a lot of the kind words about our forum, that makes me really happy and have an awesome weekend! Slightly smiling Face


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Regular
Message 15 of 18
103 Views
Message 15 of 18

Re: Display problem

Hmm, this exact same line showed up for me after replacing a cracked screen (no issues with display itself). Even at the same location on the screen.

Didn't show at first, then sometimes, now permanently for two weeks...

 

RMA on the screen will take a week not really liking that but so be it.

Sony Xperia Support
Message 16 of 18
84 Views
Message 16 of 18

Re: Display problem

Hi @Absol505, very sorry to hear about that. Slightly frowning Face

Having to send the device to repairs is never fun, but having a very annoying line there at all times is something that I would stare at and be very frustrated about it.

I hope everything goes smoothly with the repair and if you feel like it, let me know how it works after you get it back! Slightly smiling Face


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Inhabitant
Message 17 of 18
75 Views
Message 17 of 18

Re: Display problem

Yes. But it's Horizontal lines I think so. It is manufacturing defect.. You just ask him once again because every XZ2 user having the issue since we bought the mobile.

I too had it.

 

Sony Xperia Support
Message 18 of 18
53 Views
Message 18 of 18

Re: Display problem

Hi @Sivasaianirudh, sorry to hear that you have also experienced this. Slightly frowning Face

My colleagues that are or have used the Xperia XZ2 haven't had this unexpected behaviour occur, so not all Xperia XZ2 devices are affected at least.

Do I understand that your device was repaired and everything is working now again?

Thank you.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.