account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Wi-Fi looses connect after Andoid 9 update on XZ2c

Inhabitant
Message 11 of 23
1,136 Views
Message 11 of 23

Re: Bad connection under WIFI 5Ghz with Pie

After update Carrier Services today, seems my home wifi (5 ghz) works with xz2c

Visitor
Message 12 of 23
1,124 Views
Message 12 of 23

Re: Bad connection under WIFI 5Ghz with Pie

Same here, my XZ2C can find and connect to my 5GHz network but then it just shows an "X" over the wifi icon and says there's no internet. I restarted my device 4 times then actually ran a software repair from the Sony Companion on my Mac. After all the hassle, nothing has changed but I can connect to my 2.4 GHz network just fine... Sony, please fix this issue!!!!

Visitor
Message 13 of 23
1,122 Views
Message 13 of 23

Re: Wi-Fi looses connect after Andoid 9 update on XZ2c

Same. I tried software repair through sony companion but it didn't fix the issue. I can still connect to 2.4GHz wifi but 5GHz doesn't work. It will connect then tell me there's no internet then drop the network. Rinse, repeat, over and over and over.

tmx
Adviser
Message 14 of 23
1,098 Views
Message 14 of 23

Re: WiFi problems with Pie

No solution to lost WiFi yet from Sony. They do not offer any advice and ask to send the phone in for service.

Highlighted
Adviser
Message 15 of 23
1,006 Views
Message 15 of 23

Re: Wi-Fi looses connect after Andoid 9 update on XZ2c

Same issue too.... I would try a backup and restore using companion but it now does not back up apps on xperia transfer either.. I have asked the question and raised that problem too but I have had no reply from anyone on that issue either

One time poster
Message 16 of 23
980 Views
Message 16 of 23

Re: Wi-Fi looses connect after Andoid 9 update on XZ2c

Same here 

 

Im having a problems with wifi after android p update 
 
Im losing wifi every minute especially on 5ghz wifi and i see X mark on wifi icon 
 
And the wifi range is decreased after android p update 
Visitor
Message 17 of 23
918 Views
Message 17 of 23

Re: Wi-Fi looses connect after Andoid 9 update on XZ2c

Exactly the same issue here. Wifi connect/disconnect issuess after upgrade to android 9.0. 

One time poster
Message 18 of 23
815 Views
Message 18 of 23

Re: Wi-Fi looses connect after Andoid 9 update on XZ2c

Same problem here!

After the Pie update I can Connect to both 2.4 and 5 Ghz wifi but the Second one doesn't work ("no internet connection avaible").

 

Regular
Message 19 of 23
793 Views
Message 19 of 23

Re: Wi-Fi looses connect after Andoid 9 update on XZ2c

Same problem, inconstitent wifi connection. Will not always load some sites and often fails to open links from emails.  Very annoying - worked perfectly before update. Interestingly seems to be OK if I cancel WIFI and use mobile broadband (using my data allowance!!).

Sony or Google needs to sort this asap.

Apprentice
Message 20 of 23
482 Views
Message 20 of 23

Re: Wi-Fi looses connect after Andoid 9 update on XZ2c

Same here! Even with the latest firmware 52.0.A.3.163 still no fix. 

It's like Sony doesn't care .