account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Mobile data turns off when connecting to open wifi

SOLVED
Apprentice
Message 1 of 10
1,555 Views
Message 1 of 10

Mobile data turns off when connecting to open wifi

Hi,

 

Everytime my XZ2 Compact connects to an open wifi source, it drops 4G connection. This would be fine, but it will do this even if the open WiFi point can't reach the internet (for example, if I have to provide credentials for the WiFi).

 

This is awful since it interrputs streaming / gaming whilst on public transport and going past many wifi spots.

 

I don't want to have to remember to turn wifi back on every time I get home (because I will eventually forget and rack up a huge bill) so has anyone got a fix for this? 

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator
Message 2 of 10
1,549 Views
Message 2 of 10

Re: Mobile data turns off when connecting to open wifi

@MikeyPB

Try this:

Go to Settings -> Network & internet -> Wi-Fi -> Wi-Fi preferences -> Auto network switch -> Enable



Feel free to kudo this post or mark it as solution so that other users facing the same issue can find it

Disclaimer: Moderators are not affiliated with or work for Sony Mobile, their posts represent their own opinions and views. Click here to find out more about the different roles in the community.

9 REPLIES 9
Moderator
Message 2 of 10
1,550 Views
Message 2 of 10

Re: Mobile data turns off when connecting to open wifi

@MikeyPB

Try this:

Go to Settings -> Network & internet -> Wi-Fi -> Wi-Fi preferences -> Auto network switch -> Enable



Feel free to kudo this post or mark it as solution so that other users facing the same issue can find it

Disclaimer: Moderators are not affiliated with or work for Sony Mobile, their posts represent their own opinions and views. Click here to find out more about the different roles in the community.

Apprentice
Message 3 of 10
1,536 Views
Message 3 of 10

Re: Mobile data turns off when connecting to open wifi

Hey, thanks for that suggestion!

 

I'm concerned that this would prioritize networks over Wi-Fi if my wifi was weak, for example if I was at a conference or sometimes my home connection is a bit rubbish. 

 

Could you, or anyone else, maybe reassure me as to what this feature actually does? Will it ever reject a wifi connection if the wifi does have network access?

 

Thanks! 

Moderator
Message 4 of 10
1,521 Views
Message 4 of 10

Re: Mobile data turns off when connecting to open wifi

@MikeyPB

From my experience, it will not switch off Wi-Fi at all. It will just enable mobile data while Wi-Fi is on but the signal is too weak or has no internet (usually when a cross icon appears over your Wi-Fi icon). This will, of course, lead to higher consumption of mobile data, but I never noticed it will be activated when the signal is weak but the internet is still accessible.

 

Another solution for your situation is to "forget" all the open Wi-Fi networks that you pass through while traveling and require a sign-in.



Feel free to kudo this post or mark it as solution so that other users facing the same issue can find it

Disclaimer: Moderators are not affiliated with or work for Sony Mobile, their posts represent their own opinions and views. Click here to find out more about the different roles in the community.

Apprentice
Message 5 of 10
1,510 Views
Message 5 of 10

Re: Mobile data turns off when connecting to open wifi

@Quester Thanks so much! 

This is happening without me manually connecting to open wifi points in the first place, so I'm not sure forgettng them will help since they'll just be found again. 

 

I'll activate the feature and be sure to keep an eye on when wifi / 4G is active. 

 

Thanks again for your help

Apprentice
Message 6 of 10
1,467 Views
Message 6 of 10

Re: Mobile data turns off when connecting to open wifi

Does it help when you switch off the notification for open WiFi?

(I remember having seen an option to disable automatic connection to open WiFi in an older device somewhere...)

Apprentice
Message 7 of 10
1,442 Views
Message 7 of 10

Re: Mobile data turns off when connecting to open wifi

Oooh, interesting idea. I'll try it out today, thanks.

Apprentice
Message 8 of 10
1,395 Views
Message 8 of 10

Re: Mobile data turns off when connecting to open wifi

Afraid not - disabling notifications did not solve this issue! 

Apprentice
Message 9 of 10
1,331 Views
Message 9 of 10

Re: Mobile data turns off when connecting to open wifi

Next idea:

Can you see these open networks in your saved networks somewhere? Long pressing a network gives you a popup where you can disable Auto-connect for that specific network.

Tedious task, but seems to be the only way right now....

 

And I will check all my old Sony devices, somehow I recall an option to generally disable auto-connect to open networks (from all I see on the XZ2c that option has been removed)

Highlighted
Enthusiast
Message 10 of 10
1,095 Views
Message 10 of 10

Re: Mobile data turns off when connecting to open wifi

Your behaviour describes exactly what si stated in developer options...

On info about phone, build number if you tap 7 times over this, you will enable developer mode.After that you enter in Settings > Developer and there you have an option stating exactly this: 'Mobile data always active' = 'Always keep mobile data active, even when Wi-Fi is active (for fast network switching)' which is by default yes / active.

Turning this off will craete the behaviour described by you.

Maybe you decativate it without purpose, but for me, working only at home and wireless, is saved a lot of draining battery turning this option off.