account arrowhead-down arrowhead-up cart mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi problems after lasteast update 47.1.a.12.119(not fixed)

SOLVED
Adept
Message 3 of 155
4,205 Views
Message 3 of 155

Wi-Fi problems after lasteast update 47.1.a.12.119(not fixed)

After the recent update(47.1.A.12.34), I have a Wi-Fi connection problem that does not connect to the router or hardly connects. This problem is resolved only by rebooting the phone, but then for the second and third times ... no longer connects and requires rebooting. This is a problem for me and my two other friends.
What is the solution to this problem?

1 ACCEPTED SOLUTION

Accepted Solutions
Sony Xperia Support
Message 39 of 155
4,889 Views
Message 39 of 155

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

Hi Everyone,

You might experience that your phone sometimes loses the Wi-Fi connection and you need to restart the phone to get it reconnected. This is known and will be improved in the next software release. The affected software versions are 47.1.A.12.34 or earlier on Android 8.0.

However, please note that software updates are released at different times depending on the operator, market, region or country. Therefore, we cannot give you an exact date for when a specific update will be available for your device. In addition, network operators and specific markets may choose not to use the updates for specific models.

Update: Thank you for all the feedback! We understand that the improvements we introduced did not resolve the behavior for everyone.

We will keep investigating in order to provide further improvements.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

154 REPLIES
Regular
Message 1 of 155
3,832 Views
Message 1 of 155

Wi-Fi problems

I have noticed that the phone suddenly disconnects from Wi-Fi randomly. Is anyone else facing this issue?

Adept
Message 2 of 155
3,798 Views
Message 2 of 155

Re: Wi-Fi problems

Yes, that's the problem for me  and 2 friends too after lasteast update 47.1.a.12.34

whats fix it?

Moderator
Message 4 of 155
4,200 Views
Message 4 of 155

Re: Wi-Fi problems

@dn96

Your other friends are having this problem while trying to connect to the same router, or it's happening with different routers?



Feel free to kudo this post or mark it as solution so that other users facing the same issue can find it

Disclaimer: Moderators are not affiliated with or work for Sony Mobile, their posts represent their own opinions and views. Click here to find out more about the different roles in the community.

Adept
Message 5 of 155
4,195 Views
Message 5 of 155

Re: Wi-Fi problems

with all router.tp link 8901n and tp link 8961n.

We all tested various routines and there is a problem that has arisen since the recent update. There was no problem before.

Moderator
Message 6 of 155
4,192 Views
Message 6 of 155

Re: Wi-Fi problems

@dn96

Can any of you try resetting his network settings? This will erase all saved WiFi networks, APNs, and paired Bluetooth devices. Thus, you might need to re-adjust all these settings.

 

Go to Settings -> Network & Internet -> tap on the 3-dots icon on the top right corner -> Reset network settings -> Confirm by tapping "RESET SETTINGS".



Feel free to kudo this post or mark it as solution so that other users facing the same issue can find it

Disclaimer: Moderators are not affiliated with or work for Sony Mobile, their posts represent their own opinions and views. Click here to find out more about the different roles in the community.

Adept
Message 7 of 155
4,110 Views
Message 7 of 155

Re: Wi-Fi problems

No problem solved

sad

Adept
Message 8 of 155
4,107 Views
Message 8 of 155

Re: Wi-Fi problems

It needs Network reset and restart. It is solving the problem for 2 days only and then it reappear. That's very bad.

Adept
Message 9 of 155
4,101 Views
Message 9 of 155

Re: Wi-Fi problems

Exactly, but after rebooting, it only connects to the first time, but it is difficult for the next time.

How to report this problem to Sony?Is it possible Sony to fix this problem?
There are just 2 or 3 other people reporting this problem (from the xda community and others).

 

Adept
Message 10 of 155
4,080 Views
Message 10 of 155

Re: Wi-Fi problems

Seems like Sony only offers security updates which is easy since project tremble... No bug fixes since released except distortion fix. My xiami mi A1 had plenty bug fixes and it costs 170 euro.