account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Wi-Fi problems after lasteast update 47.1.a.12.119(not fixed)

SOLVED
Regular
Message 221 of 262
1,686 Views
Message 221 of 262

Re: Wifi disconnection issue

Hi paul4os

Please try to do a clean software repair with the August firmware. Install the phone as a new device, with no restore of any backups. Reinstall all your apps again... Ok, a lot of work but the only way to find out if the problem persists for you or if it is better or may be fixed...

Sometimes the incremental updates don´t work correct...

 

Best regards

prtigger

Talent
Message 222 of 262
1,652 Views
Message 222 of 262

Re: Wifi disconnection issue

me too

august patch, still with wifi drops.. unbelievable.

Regular
Message 223 of 262
1,641 Views
Message 223 of 262

Re: Wifi disconnection issue

Hi Profyler1

I can say it with a chance of 90%, that my signal loss and 2 seconds later a reconnect, under low signal strength, is fixed so far. I've the XZ1 Compact version, with the same hardware and firmware like the XZ1 (SoC). I'll hopefully get any information from Sony, what they changed in the August firmware.

 

Best regards 

prtigger 

Talent
Message 224 of 262
1,629 Views
Message 224 of 262

Re: Wifi disconnection issue


@prtigger wrote:

Hi Profyler1

I can say it with a chance of 90%, that my signal loss and 2 seconds later a reconnect, under low signal strength, is fixed so far. I've the XZ1 Compact version, with the same hardware and firmware like the XZ1 (SoC). I'll hopefully get any information from Sony, what they changed in the August firmware.

 

Best regards 

prtigger 


Everytime there is a security patch someone comes and says it was fixed just to come some weeks later and tell us the drops are there again. 

So its to early to know if your phone is really fixed.

I doubt sony changes someting that is not security related in security patches.

Message 225 of 262
1,625 Views
Message 225 of 262

Re: Wifi disconnection issue

FFS. The Security patches are directly coming from Google Android themselves not Sony. Only things that Sony is tweaking the codes is the Android OS itself. 

Apprentice
Message 226 of 262
1,558 Views
Message 226 of 262

Re: Wifi disconnection issue

Well clearly they should fire all the coders, because they are not doing their job for months now.

Highlighted
Adviser
Message 227 of 262
1,547 Views
Message 227 of 262

Re: Wifi disconnection issue

Well I'm 10 days since the update and still working. A bit slow sometimes but not dropping out.

 

Would take something special for me to bother buying Sony again tho. 

ezy
Commissioner
Message 228 of 262
1,409 Views
Message 228 of 262

Re: Wifi disconnection issue

me too.  It's been a week and I have not had a single wifi drop out

Message 229 of 262
1,340 Views
Message 229 of 262

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

Sorry to bother you but i updated to 47.1.a.12.270 and the wifi continues to randomly disconnect and it's signal is a little weak plus it takes sontimes alot of time to connect

One time poster
Message 230 of 262
1,150 Views
Message 230 of 262

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

Its a nighmare I bougth this Phone month ago everything was fine after some updates WiFi is killing me do something with this?