account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Wi-Fi problems after lasteast update 47.1.a.12.119(not fixed)

SOLVED
Message 111 of 262
1,332 Views
Message 111 of 262

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

@Sgreat How Sony can fix the WiFi issues if the Google is the one making those security update for all Android phones. Even if you recommend your friends to go for a Google Pixel 2 or a Samsung Phone with Oreo OS, they will have the same WiFi problem... 🙄

Adviser
Message 112 of 262
1,325 Views
Message 112 of 262

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

Well, even though I'm having this problem for months already,I know for sure that most people don't seem to have issues with their WiFi connection, that's why Sony is not bothering much. So it makes me wonder if that could be a hardware problem instead of soft. I actually sent my phone to official repair centre and they told me that probably the mainboard with the Wifi module is to blame and maybe they'll replace it. I'll write here when I get the phone back and see how it works

Enthusiast
Message 113 of 262
1,288 Views
Message 113 of 262

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

Still not sure if this is hardware related, but I am getting this after installing march update, and I recently did a software repair to the phone, and I am still getting the same wifi problem

Learner
Message 114 of 262
1,211 Views
Message 114 of 262

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

Hi all, 

 

I have this issue and spoke to support which were not much help. They acknowledge the issue and suggest I reboot until they can fix it.

 

I then did some research and I think this is a generic Oreo issue Google introduced in the security patches. Other devices such as the pixel 2 and Nokia 8 have it also. The reason it impacts people differently is down to how people's WiFi routers handles the issue which android is causing, some people are lucky and their routers have been patched or weren't affected. However the routers aren't too blame, basically the Oreo bug floods the network with network traffic relating to chromecasts even if you don't have one. This is causing some routers to crash, WiFi to go slow or in stale etc. Google tried to fix this in play services but it doesn't appear to have worked. 

 

I have tried a few settings I found on a Google support thread and it seems to have helped and possibly resolved it for me, although it doesn't seem to work for all. 

 

What I tried was going to settings and then Google, next in to cast media controls and disable media controls for cast devices. I also disable background data for the play services and our mesh network although not sure that's required. Also make sure you do this to any Oreo devices you have, I forgot about the wife's Nokia 8 at first doh. Now I have a stable WiFi connection on both phones for the first time in months.

 

Hope this helps some until Sony and Google get their act together and sort this.

 

Regular
Message 115 of 262
1,194 Views
Message 115 of 262

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

1 -  In my phone cast media controls was disabled...

2 -  I disable background data for the play services (it was enabled)

3 - What do you meen our mesh network ? English is not my native language, would you please explain?

 


@Kev79wrote:

going to settings and then Google, next in to cast media controls and disable media controls for cast devices. I also disable background data for the play services and our mesh network although not sure that's required.

Learner
Message 116 of 262
1,178 Views
Message 116 of 262

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

I have multiple WiFi access points which can act as one single WiFi network in mesh mode. I've disable it now so just have a single access point as on the Google thread it helped some people. I think people's mileage will vary as it depends on how your router handles the network flood caused by android. 

 

I also disabled the WiFi and Bluetooth scanning options within the location settings. 

Learner
Message 117 of 262
1,048 Views
Message 117 of 262

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

Hi,

Problem SOLVED, try this. 

1. Wi-Fi settings

2. Scroll down to Wi-Fi Preferences 

3. Auto network switch must be off. 

 

GOOD LUCK 🤞 

 

 

Enthusiast
Message 118 of 262
1,027 Views
Message 118 of 262

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

Hi thanks, someone suggested this a few months ago, unfortunately doesn't work for me. Hopefully it does for you

Adviser
Message 119 of 262
1,019 Views
Message 119 of 262

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

Conwae,

Problem is NOT solved obviously.

Auto network switch is turned off since day one, still getting regular disconnects from WiFi, fully solved only by rebooting the phone (rebooting the router doesn't solve the problem).

Glad it worked for you though

Highlighted
Enthusiast
Message 120 of 262
965 Views
Message 120 of 262

Re: Wi-Fi problems after lasteast update 47.1.a.12.34

I'm going crazy with mine now, after the January update I'd get about 5 or 10 minutes before having to turn airplane mode off and back on.

Since April update it's down to about a minute now.

It's absolutely useless.. I reset WiFi, load a page then it stops then I reset WiFi and load the nxt page until I get to the stage that I want to throw my phone out the window 😥

There are 3 other android phones and a tablet in the house with no WiFi issues at all