account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Usb -C adapter connected to XZ1 not detected without restart

Apprentice
Message 1 of 8
1,134 Views
Message 1 of 8

Usb -C adapter connected to XZ1 not detected without restart

Hi, 

 

I just bought this phone and I am experimenting with it. I I found that when I connect a USB drive using a USB-C to USB-A adapter, nothing shows up. I cannot find detect USB devices in the settings menu. But if I restart my phone then it detects the device. It also says that the phone is supplying power to the USB..If I disconnect it then I need to restart again to detect the USB  

 

The same adapter and USB connected to another phone like a Samsung works fine and an option pops up asking for a choice. 

 

What can I do to get this working on the Xz1? 

7 REPLIES 7
Apprentice
Message 2 of 8
1,123 Views
Message 2 of 8

Re: Usb -C adapter connected to XZ1 not detected without restart

Anyone??

 

SONY?? 

Pioneer
Message 3 of 8
1,107 Views
Message 3 of 8

Re: Usb -C adapter connected to XZ1 not detected without restart

Hi @kaputme;

 

I don't know why it doesn't get detected when you connect it as in my XZ Premium (same firmware) when I connect the adapter with the USB drive after 3 seconds it gets automatically detected, I don't need to restart the phone. Don't know if it is different in XZ1.

Apprentice
Message 4 of 8
1,095 Views
Message 4 of 8

Re: Usb -C adapter connected to XZ1 not detected without restart

On very very close inspection I found that the connector is not going fully in, like the cable provided with the phone .

The connector end looks different as well . May be I have to try another adapter.. 

One time poster
Message 5 of 8
1,084 Views
Message 5 of 8

Re: Usb -C adapter connected to XZ1 not detected without restart

Settings -> Device Connection -> USB Connectivity -> Detect USB device?

Apprentice
Message 6 of 8
1,079 Views
Message 6 of 8

Re: Usb -C adapter connected to XZ1 not detected without restart

Well this option is greyed out and says no connected device.

Apprentice
Message 7 of 8
1,024 Views
Message 7 of 8

Re: Usb -C adapter connected to XZ1 not detected without restart

Looks something very fishy..

 

i bought another type of usb abadper.. Micro USB to USB-C.. even that seems not to be detected.. but the original cabel. What is going on?..

 

Any sony rep here to answer??

Highlighted
Regular
Message 8 of 8
385 Views
Message 8 of 8

Re: Usb -C adapter connected to XZ1 not detected without restart

Same sort of problem here. My Seek Thermal USB camera always had to be detected manually on my Sony Z5 on Android 7.1.1, and then it worked fine. However, it also doesn't get auto-detected on Android 9 on my Xperia XZ1 but with the manual USB detection option gone in Android 9, I cannot use the thermal camera anymore (restarting the phone with the thermal camera plugged in does not solve the problem). Why was the manual USB detection option removed (and moreover why are Sony phones apparently not able to detect this device)?