account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

USB Host/OTG not working after upgrade to Android Pie 9.0 build 47.2.A.0.306

Adviser
Message 1 of 11
8,948 Views
Message 1 of 11

USB Host/OTG not working after upgrade to Android Pie 9.0 build 47.2.A.0.306

Hi,

 

Before updating to 47.2.A.0.306, which brought Android Pie / 9, USB-Host / OTG was working perfectly.

USB-Flashdrives, USB-Mouse, USB-Keyboard, USB-SmartScope Oscilloscope, etc. everything worked as expected. (via Adapter)

 

Since the update to 47.2.A.0.306, USB-Devices connected to my phone are no longer recognized.

I can still charge my phone and connect it to my PC without problems.

In Settings->USB Preferences  all Options stay grayed out if a USB-Devices is connected

in Settings->USB Connectivity there is a button "Restart USB device auto-detection", which also stays grayed out. The gray text below reports "USB device auto-detection is active".

 

Despite this, USB-Host/OTG simply does not work!

10 REPLIES 10
Pioneer
Message 2 of 11
8,937 Views
Message 2 of 11

Re: USB Host/OTG not working after upgrade to Android Pie 9.0 build 47.2.A.0.306

Hi @BerndT;

 

Just tested it in my XZ Premium with same firmware (with two different USB sticks via USB-C adapter) and the USB OTG is working normally, I can even tell it is detected faster then with Android 8.0.

Try restarting the phone to see if it helps.

Adviser
Message 3 of 11
8,888 Views
Message 3 of 11

Re: USB Host/OTG not working after upgrade to Android Pie 9.0 build 47.2.A.0.306

Even though I tried this before, it's worth trying it again.

 

So, today after charging it over night, unplugging it and taking it with me and then after staying in a dry warm office for a few hours, I switched the phone off, let it rest for 2 hour and switched it back on and tried again:

 

Result: Still does not work! USB-Host ist still not detecting any device I connect to the phone.

 

Before you ask: I have 4 different types of USB-OTG connectors here, 2 are new, 2 are confirmed to work previously. None work now.

 

I suspect a problem with the XZ1 hardware drivers (USB moisture detection?) and Android Pie

Pioneer
Message 4 of 11
8,874 Views
Message 4 of 11

Re: USB Host/OTG not working after upgrade to Android Pie 9.0 build 47.2.A.0.306

@BerndT;

 

I doubt there is a problem with the drives since I was able to do it with the same exact firmware.

Have you tried to restart the device in safe mode?

Did you tested any USB Flash Drive?

If none of that works maybe you should try a factory reset; or better a software repair with Xperia Companion.

Highlighted
Adviser
Message 5 of 11
8,835 Views
Message 5 of 11

Re: USB Host/OTG not working after upgrade to Android Pie 9.0 build 47.2.A.0.306

_20181124_161039.JPGThe test devices

 

_20181124_161256-01.jpegOTG / USB-C-Host cables

 

So, I charged the phone over night while powered off and powered it on while still charging. (Xperia Z1 had some strange hw behaviour when powered on while still charging, so my hope was to maybe jog the hw of my XZ1 as well a bit)

Then I bootet to safe mode right away and tried the USB-OTG cables. It provided some devices with power, so this was new! 😀 Then I rebootet again to normal mode and tried again.

 

Not sure what it was but something changed and now the current state is weird when when considering my test adapter cables a,b,c and d.

 

Cable d worked on Android 8. It is a USB2.0-microusb-OTG cable with an microusb2usb-c adapter.

 

Adapter b did nothing in Android 8 and previously I thought it defect.

 

Adapter a and c are new.

 

The new state od things is as follows.

 

Cable d has stopped working and is no longer recognized by the Xperia XZ1.

 

Adapter c also does not work.

 

However, adapters a and, strangely, b now work with all test devices! 😀

 

So my problem is halfway solved.

 

The remaining issues are:

A) I'd like to know whats going on, whats the difference between the connectors and why support for one type was dropped why support for another type was introduced.

B) Hardware that has the old style OTG Connector built in, still does not work

 

 

Adviser
Message 6 of 11
8,735 Views
Message 6 of 11

Re: USB Host/OTG not working after upgrade to Android Pie 9.0 build 47.2.A.0.306

All Adapters work perfectly fine on a friends Samsung.

So is this connected to the firmware update, or did part of my newly bought Sony Xperia XZ1's hardware die?

One time poster
Message 7 of 11
8,581 Views
Message 7 of 11

Re: USB Host/OTG not working after upgrade to Android Pie 9.0 build 47.2.A.0.306

Таже проблема!

 Same problem!

gt

Visitor
Message 8 of 11
8,398 Views
Message 8 of 11

Re: USB Host/OTG not working after upgrade to Android Pie 9.0 build 47.2.A.0.306

Same problem

Message 9 of 11
7,343 Views
Message 9 of 11

Re: USB Host/OTG not working after upgrade to Android Pie 9.0 build 47.2.A.0.306

Same problem with 47.2.A.4.45

Fixed. You must use a usb c to 3.0 adapter 

Message 10 of 11
7,244 Views
Message 10 of 11

Re: USB Host/OTG not working after upgrade to Android Pie 9.0 build 47.2.A.0.306

Fixed. You must use a usb c to usb 3.0 adapter