account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

Smart lock is missing xz1 / Bluetooth issue

SOLVED
Learner
Message 1 of 7
5,647 Views
Message 1 of 7

Smart lock is missing xz1 / Bluetooth issue

Hi. After latest update 47.1.a.2.374 smart lock feature doesn't work any longer. The menu options in smart lock are absent it is just a blank space. Before update it worked fine. 

 

The second problem is with the Bluetooth connection - my swr12 bracelet regalarly looses signal and reconnects. The problem existed before update and is still in place. 

1 ACCEPTED SOLUTION

Accepted Solutions
Inhabitant
Message 2 of 7
9,209 Views
Message 2 of 7

Re: Smart lock is missing xz1 / Bluetooth issue

Smart lock issues see here:

 

https://talk.sonymobile.com/t5/Xperia-XZ1-Compact/Smart-Lock-empty-after-update/td-p/1268741

 

As for Bluetooth: You can find various troubleshooting tips in this forum (Just search for Bluetooth), but most probably this is a general issue with Oreo and won't be fixed until Google releases a patch that removes all possible causes.  

6 REPLIES 6
Inhabitant
Message 2 of 7
9,210 Views
Message 2 of 7

Re: Smart lock is missing xz1 / Bluetooth issue

Smart lock issues see here:

 

https://talk.sonymobile.com/t5/Xperia-XZ1-Compact/Smart-Lock-empty-after-update/td-p/1268741

 

As for Bluetooth: You can find various troubleshooting tips in this forum (Just search for Bluetooth), but most probably this is a general issue with Oreo and won't be fixed until Google releases a patch that removes all possible causes.  

Adviser
Message 3 of 7
5,507 Views
Message 3 of 7

Re: Smart lock is missing xz1 / Bluetooth issue

This thread isn't solved.. The smartlock fix is temporary. After restarting the phone, it dissappears again. Can we please escalate this. 

Apprentice
Message 4 of 7
5,335 Views
Message 4 of 7

Help me?

Screenshot_20171116-162957.png

 

Why smartlock is that?

 

Inhabitant
Message 5 of 7
5,284 Views
Message 5 of 7

Re: Help me?

turn off smart lock in trusted agents, restart and enable. It's a temporary fix, yes, but personally I don't change my smart lock stuff on a daily basis. It should get a fix, but I would pick different priorities.

Apprentice
Message 6 of 7
5,263 Views
Message 6 of 7

Re: Help me?

Thanks. 

Highlighted
Adviser
Message 7 of 7
3,333 Views
Message 7 of 7

Re: Help me?

I don't think that it is a general Android 8 Oreo issue. The problem only exists with those phones that were originally delivered with Android 8, such as our XZ1 and XZ1 compact.

Older phones, like our XZ and X Compact, that have received Oreo as an software update, don't have the problem, Smart Lock is working perfectly fine with these devices, even after restarts.

Hope that the April Update .145 will finally fix it.

 

Edit/Update: Just installed .145. Problem is still there :-( Smart Lock menu is still empty after restart so that the known workaround with disabling Trust Agents Smart Lock, restart, enabling Trust Agents Smart Lock is necessary.