account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Power button, volume button and vibration not working

One time poster
Message 1 of 5
489 Views
Message 1 of 5

Power button, volume button and vibration not working

I completed the new update onfriday evening and since Saturday morning my power button, volume button and vibration isnt working on my phone, its less than 12 months old, no visual damage always had a cover and screen protector. Very confusing and frustrating. Ive tried the restart obviously already dont the update, habent yet tried the factory reset, any suggestions?? Or anyone had a simlar problem, EE store say its needs sending off but dont have a loan phone and i dont have insurence. So would be without a phone for 2wks, which id struggle with due to work.

 

Thanks in advanced! 

4 REPLIES 4
Visitor
Message 2 of 5
472 Views
Message 2 of 5

Re: Power button, volume button and vibration not working

I'm having the same problem and my xz1 device was purchased in October 2018

 

Estou com o mesmo problema e meu aparelho xz1 foi comprado em outubro de 2018

 

@MariM89 

 

I've edited your post as this is an English only forum, you can use Google Translate to reply and/or post.

Emperor
Message 3 of 5
465 Views
Message 3 of 5

Re: Power button, volume button and vibration not working

@Tlacey  @MariM89 

 

I'm sorry to hear that, have you dropped the phone or exposed it to water, steam, etc? 

 

Have you repaired the device with Xperia Companion?




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Visitor
Message 4 of 5
459 Views
Message 4 of 5

Re: Power button, volume button and vibration not working

I have not been able to repair with the Xperia companion yet, tomorrow I will try. I tried the assistant by the phone itself, but I stopped at the fingerprint reader that Tb is not working

 

Ainda não consegui reparar com o Xperia companion, amanhã vou tentar. Tentei o assistente pelo próprio telefone, mas parei na leitora de impressão digital  que Tb não está funcionando  

Apprentice
Message 5 of 5
373 Views
Message 5 of 5

Re: Power button, volume button and vibration not working

This also happened to my XZ1. I took it to the workshop and they told me that the circuits had been disconnected due to an increase in temperature.

The buttons were soldered and the problem was solved.