account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Physical buttons stop working in XZ1

Apprentice
Message 1 of 8
741 Views
Message 1 of 8

Physical buttons stop working in XZ1

A couple of weeks ago, after the patch update in January, my XZ1 started with failures: 

 

1. Volume controls stopped working
2. Fingerprint sensor does not work and functionality was hidden in the configuration.
3. Physical camera button does not activate the application.

 

I did Diagnostic tests and neither the vibration and the gyroscope work.

 

I have restored the factory and then a repair with Xperia Companion but nothing solves the problem.

 

It is impossible for it to be hardware failure since I have taken care of it a lot.

 

I have reported this to Sony Support and they tell me that they do not have a solution.

 

Does anyone have a good tutorial for flashtool and go back to Oreo?

7 REPLIES 7
Emperor
Message 2 of 8
729 Views
Message 2 of 8

Re: Physical buttons stop working in XZ1

@Pepe123986 

 

I'm sorry to hear about the issue, but what you describe seems like a hardware related issue rather than software, flashing back to a previous android flavor won't solve, it'll be wise to contact Sony again and send it in. 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Emperor
Message 3 of 8
727 Views
Message 3 of 8

Re: Physical buttons stop working in XZ1

@Pepe123986 

 

Here is a guide

 

https://talk.sonymobile.com/t5/Xperia-Z-ZL-ZR/How-to-manually-update-downgrade-root-2013-Xperias/m-p...

 

a bit old but will do 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Enthusiast
Message 4 of 8
710 Views
Message 4 of 8

Re: Physical buttons stop working in XZ1

If Sony cannot repair the malfunction. Require sony to replace Experia XZ1 with a new serviceable XZ1 - or return the money by check.

Emperor
Message 5 of 8
703 Views
Message 5 of 8

Re: Physical buttons stop working in XZ1

@Sanche101 

 

I don't have such info, you have to contact your >>> Local Support team regarding that info




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Visitor
Message 6 of 8
667 Views
Message 6 of 8

Re: Physical buttons stop working in XZ1

about "2. Fingerprint sensor does not work and functionality was hidden in the configuration."

 

Had same issue on a Xperia Z5 Premium like a year ago.

 

1. Try starting phone in safe mode and look if configuration options of fingerprint are there / if fingerprint is working --> this solved it  for me the first time it happened

 

2. after a while and a next update fingerprint was gone again and solution 1 did not work anymore - hard reset also not helpful, so was software related.

 

3. had been fixed like half a year later with another update when all of a sudden it was there again.

 

So all in all sounds like the same issue.

Apprentice
Message 7 of 8
662 Views
Message 7 of 8

Re: Physical buttons stop working in XZ1

Hi

Had same issue with my Xz1 recently after patch update

Luckily in warranty, sent back to EE who fixed it very quickly. 

Decent phone, bad software 

Shame on Sony, turned off my software updates  

Contact your network provider if in contract, good luck. 

Apprentice
Message 8 of 8
574 Views
Message 8 of 8

Re: Physical buttons stop working in XZ1

Friends, I tell you that I installed a version of Android 8 with FlashTool and the issue was not corrected with the volume control and the fingerprint. But I'm sure the volume buttons work since to use FlashTool I had to use the Volume Down button and it worked fine. It is unfortunate what has happened to many users of the XZ1. A great phone that ruined us.