account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

My time with Android 9 so far.

Highlighted
Adept
Message 1 of 1
1,324 Views
Message 1 of 1

My time with Android 9 so far.

So flashed my phone using another carriers firmware.

 

I must say I am enjoying it. 

All my functions work flawlessly i.e. WiFi, Bluetooth, LTE, calls, screen brightness, fingerprint scanner, speakers, all apps are running/updating etc.

 

Battery is VERY good!!!!!!

 

Yes it is missing key features but I'm not too worried about that. All issues in the forum regarding this update I am not experiencing at all.

 

I would recommend flashing using xperifirm and newflasher. It will wipe your phone so be sure to backup. Here is a tutorial I used. Farelly easy to use.

http://www.xperiablog.net/2018/01/28/newflasher-guide-to-install-new-firmware-for-xperia-xz-premium-...

 

I'm thinking that the OTA is a "dirty flash" that's why problems are occurring.

 

Also I'm using Lawnchair launcher which adds to experience.

https://www.apkmirror.com/apk/deletescape/lawnchair/lawnchair-2-0-698-ci-alpha-release/lawnchair-2-2...

 

My firmware version in the attachment.Screenshot_20181208-110836.png