account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

LTE connection has multiple problems after updating to android pie

One time poster
Message 1 of 2
1,283 Views
Message 1 of 2

LTE connection has multiple problems after updating to android pie

Everytime after I connect to a wifi and want to connect back to the LTE network, I have to reboot the phone, otherwise it would just stray unconnected to the internet. Even turning on and off the flight mode cannot solve it, only rebooting.

 

What is worse: I cannot make phone calls at all. I receive sms that were sent days ago randomly and keep missing new messages. 

 

Not to mention other small problem, such as the crasy automatic brightness level that always sets itself much brighter than needed, and the fast battery consumption. 

 

The phone is almost unusable now. What should I do to make it function...?

 

1 REPLY 1
Highlighted
Adviser
Message 2 of 2
1,241 Views
Message 2 of 2

Re: LTE connection has multiple problems after updating to android pie

huh,interesting that it doesn't connect back to LTE. For the issue with phone calls - look if your network is set to LTE(preffered)/WCDMA/EDGE(or whatever). And if it is - maybe try using 3G and after a few seconds go back to LTE and see if it fixes it.Also check if your sim card is in the right place,alot of the times it's a simple issue with a simple solution - others,it's not. You could try to "repair" your firmware using the xperia companion app. You could also download the old firmware from xperifirm and learn how to flash it (xda forums),but that's complicated and has about 1% chance of something going wrong and soft bricking your device,so I really wouldn't go that deep. gl