account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

Faulty screens or normal behaviour??

Apprentice
Message 1 of 11
2,084 Views
Message 1 of 11

Faulty screens or normal behaviour??

I currently have 2 XZ1 phones to hand, 1 in Black and 1 in Moonlit Blue and both have this issue.

Try rubbing your screen when the screen is off (as if you are removing fingerprints) then straight away turn your screen on - Do you have horizontal Lines and white dots on the display??

 

As I say both the devices have this issue/characteristic.

10 REPLIES 10
Adviser
Message 2 of 11
2,062 Views
Message 2 of 11

Re: Faulty screens or normal behaviour??

Also my XZ1 has the same problem.

Highlighted
Regular
Message 3 of 11
2,027 Views
Message 3 of 11

Re: Faulty screens or normal behaviour??

My friend, Link this topic with my topic. We must thumbs up this subject.

Pioneer
Message 4 of 11
2,001 Views
Message 4 of 11

Re: Faulty screens or normal behaviour??

Static electricity?

With what are you rubbing: wool, synthetic, fingers?


who knows knows
who doesn't doesn't
Regular
Message 5 of 11
1,955 Views
Message 5 of 11

Re: Faulty screens or normal behaviour??

no problem on my black g8342 after rubbing it 

Forum Legend
Message 6 of 11
1,923 Views
Message 6 of 11

Re: Faulty screens or normal behaviour??

I tried this with my xperia xz1. the issue appears when you rub the screen very hard, in which the glass comes in contact with digitizer inside the device, just like when you rub a laptop screen.

 

so when you are cleaning your screen , do not apply heavy pressure.,



________________________________________________________________________________
The Man! The Myth! The Forum Legend! -Scott Sterling
Apprentice
Message 7 of 11
1,917 Views
Message 7 of 11

Re: Faulty screens or normal behaviour??

This happens with my device even with very little pressure, they have even appeared when just using the swipe on the keyboard? Maybe there is only a small gap between digitizer and screen on my XZ1?

I have sent the phone off to the Sony repair centre so will update with their findings.

Inhabitant
Message 8 of 11
1,895 Views
Message 8 of 11

Re: Faulty screens or normal behaviour??

No problem with my black xz1

Apprentice
Message 9 of 11
1,852 Views
Message 9 of 11

Re: Faulty screens or normal behaviour??

  • I have just noticed the issue. Yes after  cleaning the screen and waking up the display.

i have seen one photo on XDA too. Exactly the same with mine.

 

https://forum.xda-developers.com/xperia-xz1/help/horizontal-lines-dark-spots-screen-t3704107

 

horizontal stripes with white dots in certain places. Looks pretty bad to me. 

Not sure if I need to send it to repair

 

 

Enthusiast
Message 10 of 11
1,843 Views
Message 10 of 11

Re: Faulty screens or normal behaviour??

Same issue..... appears with normal force like cleaning the screen....Noticed it yesterday night not sure what caused the issue. Never noticed that in any sony phone since Xperia S...

Rubbing the screen makes it look odd with Horizontal lines and white patches.