account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

XZ1 Compact GPS not working after Android PIE update

Apprentice
Message 61 of 62
587 Views
Message 61 of 62

Re: XZ1 Compact GPS not working after Android PIE update

I was happy, because my GPS worked like a clock, untill I left Sweden and turned The Phone into "flightmode" then everything about wher I am, stoped working?? I am now in Murmansk, trying to follow where I go, but it does not work at all?

I also tryed my app "GPS test" and it shows apr. 30 satelites is visible but no fix?? Then I guese that gps is working, but not showing my position in any app!?!? Why? And as always I say, what is Sony doing About it?? Or are they expecting that The user fix it?? And now I am trying to ad a screeshot of GPS test, but that is a fail?? Screenshot_20190830-102924.png

 

One time poster
Message 62 of 62
560 Views
Message 62 of 62

Re: XZ1 Compact GPS not working after Android PIE update

I have tried many options - so my gps works  bad, sometimes. It works fine for whole week, fix during a few seconds, accuracy about 5m. A then, suddenly, without some reason, works bad or at all. Gps test app shows 26 satelits and my XZ1C connects nothing. This situation takes for example a half day and then, without any changes, it works...

I'm thinking about returning to Oreo.

Does it make any sense?