account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

XPERIA XZ1 GPS doesn't work after PIE Android Update.

One time poster
Message 1 of 4
2,336 Views
Message 1 of 4

XPERIA XZ1 GPS doesn't work after PIE Android Update.

After Updating to Android PIE GPS seems not to work. The Navigation Softwar says "Waiting for GPS" and nothing happens.

I found a workaround in the XPERIA Support Forum:

Type in the Xperia test Phone number to go in the gps settings :

*#*#7378423#*#*

Select gps, then purge test data

Then reboot.

After that GPS works. But as noted in the Support Forum it works only for a while. Then same procedure again.

kwandel

3 REPLIES 3
Adept
Message 2 of 4
2,321 Views
Message 2 of 4

Re: XPERIA XZ1 GPS doesn't work after PIE Android Update.

Same here, after update to pie GPS is useless 

Highlighted
Visitor
Message 3 of 4
2,183 Views
Message 3 of 4

Re: XPERIA XZ1 GPS doesn't work after PIE Android Update.

Hi everyone,

I have the same issue. This happened as soon as I've updated to Pie...

Will Sony update the phone?

Waze do not manager to find any GPS signal... It's very annoying...

I contacted the support team but they have a standard answer: reset your phone...

Inhabitant
Message 4 of 4
2,173 Views
Message 4 of 4

Re: XPERIA XZ1 GPS doesn't work after PIE Android Update.

They did the same to me, but instead of the GPS they wrecked my NFC. Standard answer: repair (clean reinstall). Obviously it doesn't help. I've sent back the phone to them (still under warranty).

 

If this does not work after a factory reset, repair via Sony Companion, then the only way to solve is to send back to them... Their updates can't be trusted at all...