account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

Wifi connection problem

Regular
Message 101 of 108
1,953 Views
Message 101 of 108

Re: Wifi connection problem

Does anyone remember after which patch this nightmare began? maybe in it you can find the reason where to drip ..

 

Once again, when a problem appeared, I simply disconnected the wifi and started using the mobile Internet, it was impossible to restart the phone. an hour and a half later I turned on - I saw all the networks, I connected to the right one and at maximum speed. network cache !?

Highlighted
One time poster
Message 102 of 108
1,770 Views
Message 102 of 108

Re: Wifi connection problem

I've always had Sony phone's and always, after a while of ownership and a few updates, experienced the same wifi/connectivity issues.

I am probably on my 5th Gen Sony/Xperia and still this issue has not been fixed.

All devices have their faults but this is the last Xperia for me.

If Sony and Google can't solve it in over 8 years, then they don't deserve our custom.

I've not heard of this issue with Samsung so I'll give the S10+ a go next.

One time poster
Message 103 of 108
1,718 Views
Message 103 of 108

Re: Wifi connection problem

I got the same problem after the 47.2.A.6.30 update. First I had to restart once in about a week to bring the wifi signal back, now it's failing constantly, like several times a day. And I was very surprised to so many have the same problem and sony not doing anything to fix it. 

Regular
Message 104 of 108
1,175 Views
Message 104 of 108

Re: Wifi connection problem

I continue to notice strangeness. during the last month I didn’t have to reboot, but the problem was. The phone stopped working on the Internet, the network speed indicator (installed a third-party program) showed that all attempts to speed up the download were failed, the phone became worse to keep the network connection level (jumped divisions of the Wi-Fi antenna +/- 1 division) and in the properties of the network connection (item connection speed) showed from 1 to 32 mb.s (144 with excellent working connection) + heats up a little. sony spying?

One time poster
Message 105 of 108
1,036 Views
Message 105 of 108

Re: Wifi connection problem

I've got the same issue, but it finally went out for good.

I've only had this phone (XZ1 compact) for a year. My Z1 compact only lasted 2 years. My Droid X lasted 6 years.

 

For the past 5-6 months it would have occasional connection issues to wifi. Rebooting or cycling Airplane mode would fix it. It's been happining more frequently as time goes on.

I know it's not from a recent update because Windows has taught me not to update unless I want to wipe my device when their update breaks it. I only update my laptop and phone once a year when they start getting cluttered and slow (clean install) and I expect them to last at least 4 years.

 

About a month ago this phone suddenly wouldn't turn on WIFI. It tried, then it just turned WIFI back off. After rebooting, it said no SIM card inserted. No WIFI or Bluetooth either. Reboot again and it works.

Over the next few days, it worked less and less. I even did my yearly wipe and update. I've troubleshooted the SIM mechanical connection and changed Sim cards. It finally crapped out. I haven't gotten any network stuff working in 2 weeks. I just swapped the 3 antenna pieces out and checked for loose connections. Nothing.

I'm on a $20 prepaid phone. I think I won't be spending $500 on a phone again. Especially since you can't find a phone under 5" in the U.S. anymore. Planned obsolescence is becoming a real problem.

 

I'm about to cook the logic board in the oven. The way we used to cook the XBOX 360.

I can't figure out which chip is for the WIFI/Bluetooth, so the whole thing goes in the heat.

Oid
One time poster
Message 106 of 108
951 Views
Message 106 of 108

Re: Latest update (145) wifi issues.

My XZ1 Compact Connects with my wifi but just says "no internet". Try as I have I cannot regain the internet connection which was fine until recently. Something I have done unwittingly I suppose. Can anyone come to my assistance please?

Rookie
Message 107 of 108
919 Views
Message 107 of 108

Re: Latest update (145) wifi issues.

Since last update, the wifi is very slow. I test it with Wifi Analyzer and it seems to change a lot during a day.

 

The quality is good, the connection is stable but the debit is really really slow (5-6 mbps)...

 

Any idea ?

One time poster
Message 108 of 108
223 Views
Message 108 of 108

Re: Wifi connection problem

i solved the issue by adding an exception for wifi in battery saving management. 

 

MY Phone is in french so i'm not sure of the correct menu translation but here's what i did :

 

Go to the settings menu > battery > advanced settings. On the applications list, select wifi. Select power saving functions. Go to the system tab and select wifi.

 

If you don't have access to the apps list in the battery menu, You can find It this way :

Settings > applications. Display all remaining applications. On the top right corner, click on the three dots and select display system procès, find wifi and click on It. Click on advanced options, then battery, then power saving functions. Go to the system tab and select wifi. 

 

And it's done Slightly smiling Face 

 

It worked for me !

 

Hope it'll help !