account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

Wifi connection problem

Regular
Message 21 of 108
2,988 Views
Message 21 of 108

Re: Wifi connection problem

Update on my part:

Nevermind it's back.

Contact support and send them this thread.

Talent
Message 22 of 108
2,968 Views
Message 22 of 108

Re: Wifi connection problem

Yesterday I opened a chat session with Sony.

When describing my problem I included the link to this thread.

The "technician" said he never heard of the problem.

He also said he has an Xperia XZ1 Compact and, "it works normally".

He said I have to send it in for "repairs".

He will be sending me an RMA and FEDEX label.

Talent
Message 23 of 108
2,924 Views
Message 23 of 108

Re: Wifi connection problem

Today I woke up to a message that Sony had an update to my phone.

I installed it.

My Build number is 47.1.A.12.145.

I don't know if that is new or not.

 

Could it be that I got a repair?

Did others get an update?

 

Enthusiast
Message 24 of 108
2,910 Views
Message 24 of 108

Re: Wifi connection problem

May be you are in the US

No, it's not solved 

Talent
Message 25 of 108
2,879 Views
Message 25 of 108

Re: Wifi connection problem

It just went back to Connected, no internet.

Everything else on wifi in the house is getting the internet just fine.

This think isn't.

Sony Repair Center was supposed to email me a shipping lable on May 2.

Nothing came so I prompted them on the 3rd.

No response.

Now it is the 5th and nothing since the 2nd.

 

Sevdar, yes I am in the States.

 

Problem Not Solved!

I opend another chat session and got all the same promises.  When I questioned why there was no follow up from the last session "Paula C" said " the responsible department needs to check all the information and proceed"

So, it takes three days to "check...."

Visitor
Message 26 of 108
2,851 Views
Message 26 of 108

Re: Wifi connection problem

By now I've read a lot about this problem of random disconnection of wifi since I'm also having this issue on my XZ1 Compact. It seems that it is occurring on the newer phones with Android 7+ but no general statements can be made here. Fact is, however, Sony couldn't fix this problem for nearly a year and therefore I'm afraid it is probably a hardware issue. Sony doesn't clarify whether it is software or hardware related seems to mean that they cannot fix it by software updates. So I would suggest putting more pressure on Sony so they make a clear statement of whether or not giving back the device and take advantage of the warranty.

Talent
Message 27 of 108
2,844 Views
Message 27 of 108

Re: Wifi connection problem

I am trying to return it "for repair".

I have had two different people (chat sessions) say they will send me the RMA, instructions, and FEDEX label.

One promised it in 15 minutes, the other in 20 minutes.

The 15 minute promise expired days ago.

The 20 minute promise expired 18 hours ago.

Nothing in my Spam folder.

I know of only two ways to put pressure on.

(1) Reviews.....I described my problems in my review on Amazon.  I will be adding the RMA problems when I get a chance.

(2) Try to return it under warranty.

The more of us that do it, the sooner the problem gets fixed.

 

My $0.02

 

This is an update.  I just received the return information.  25 minutes after posting the above.  I don't think there is any connection.

Talent
Message 28 of 108
2,785 Views
Message 28 of 108

Re: Wifi connection problem


@rilobanwrote:

By now I've read a lot about this problem of random disconnection of wifi since I'm also having this issue on my XZ1 Compact. It seems that it is occurring on the newer phones with Android 7+ but no general statements can be made here. Fact is, however, Sony couldn't fix this problem for nearly a year and therefore I'm afraid it is probably a hardware issue. Sony doesn't clarify whether it is software or hardware related seems to mean that they cannot fix it by software updates. So I would suggest putting more pressure on Sony so they make a clear statement of whether or not giving back the device and take advantage of the warranty.


Yeah its odd.

I dont have this on my XZ1C. I actually had it for some time , like a week or so, but then it completely dissapeared without any type of repais & changes. and i dont have wifi drops, using multiples routers (2 and 5g). 

But then my parents Moto G4, has the exact same problem.. Moto G4 and 5 forum is also crowded with people with WIFI drops problem... Kinda difficult to tell if its a manufacturer problem or Android, but then, i also dont know if people with Pixel phone Samsung S series are haveing this problem, too.

Anyway this should not be a excuse and Sony and the other should fix this even if its a Android thing.

Commissioner
Message 29 of 108
2,755 Views
Message 29 of 108

Re: Wifi connection problem

I have friends & colleagues with Samsung S8 / S9 / Note 8, Nokia 6, Pixel 2, Huawei P20, LG V30. All these handsets are also running Oreo but no-one else has this issue.  In actual fact the only other person I know that has also WiFi issues is someone with a XZ1 (not compact) - yes - another Sony device.

 

If it really is an Android bug I can only think it only affects certain hardware implementations that none of the above devices use. They all seem to use Snapdragon 835 as the chipset so I'd be surprised if its the WiFi module itself. I think it's way more likey that Sony (and by the sounds of it maybe Motorola too) have broken something in the software when implimenting their own custom flavour of Oreo. If it was a widespread Oreo issue you'd expect everyone to be having the issue and it being widely reported across multiple / all manufacturers (eg. like the Smartlock bug).

Highlighted
Talent
Message 30 of 108
2,726 Views
Message 30 of 108

Re: Wifi connection problem

I returned my XZ1-C Yesterday for repair.

This is the description I included in the package:

*******************************************************************

Xperia XZ1 Compact.

IMEI Deleted

Service Request: Deleted

 

The Problem.  I have owned this phone since January.  Some time in March, I believe just after a software update, it began exhibiting this very frustrating problem.

 

Every day or so it will lose the connection to the internet.  It reports that it is "Connected, no internet" when on my home wifi network.  Note, all the other devices on this wifi network remain connected to the internet.  They include a Samsung cellphone, an iPhone, an iPad, a Windows 8 tablet, and a Windows 8 desktop.

 

This problem is very frustrating because:

 

(1) It causes my phone to change to using data from my cell provider data plan.  I pay for a very limited data plan because I have access to wifi nearly everywhere I go.  There are times when I will not notice that I have lost the internet and use a lot of my data plan.  Or I will get a notification that "8 apps have been updated" and I see that my phone is "Connected, no internet".   I check my data plan and see that my phone used 200 Megabytes of my monthly data allotment just for the automatic app update.

 

(2) When this happens, the only way to get the internet back is to reset the phone.  That leads to more hassle because after the reset, the "Smart Lock" screen is empty (blank).   That means I have to go to "Trusted Agents" and disable, "Smart Lock (Google)".   Then I have to reset the phone again then return to "Trusted Agents" and enable, "Smart Lock (Google)".  

 

(3) In order to try to fix this problem I used "Xperia Companion" to "Software repair".  Well, that didn't work but, even though I backed up my phone using Xperia Companion as instructed, when I used Xperia Companion to restore the phone, in found that none of my installed apps were restored.  I previously had 106 apps installed on the phone.  I spent over 6 hours reinstalling and restoring settings for just 86 of those apps when I discovered that I had another "Connected, no internet" meaning that I just wasted 6 or 7 hours that didn't solve the problem.