account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Wifi connection problem

One time poster
Message 1 of 107
13,950 Views
Message 1 of 107

Wifi connection problem

It all started normally, the phone connected to the wifi just fine. Then as time passed, just a few weeks, the phone started to have big trouble connect to the wifi although the signal is excellent, it gets unconnected back and forth and the connection is very slow compare to other phones. Any know how to fix it? Thanks

106 REPLIES 106
Inhabitant
Message 2 of 107
13,926 Views
Message 2 of 107

Re: Wifi connection **bleep**

Reset  Restart the phone and you will be a ok for a cuple of days. If that does not work, do a reset of wifi settings and restart the phone.

 

This is annoying for me as well, and i'm in the latest update (145).

Highlighted
Inhabitant
Message 3 of 107
13,944 Views
Message 3 of 107

Latest update (145) wifi issues.

Indeed. I'm having now connectivity issues that are solved after rebooting the phone eveery couple of days. This was *not* the case with previous updates.

Talent
Message 4 of 107
13,903 Views
Message 4 of 107

Re: Wifi connection problem

The wifi gets disconnected frequently... I didnt face this problem so regularly before april patch... what's wrong with my xz1c... Support team please forward this problem to department in charge ASAP. Thanks

Talent
Message 5 of 107
13,824 Views
Message 5 of 107

Re: Wifi connection problem

I also have wifi problems.

It seems to be happening about daily.

I will notice network problems and see that the wifi symbol is on the top screen but there is a symbol on top of it.  Maybe a "X" or maybe a "+".  Too small to tell.

If I go to Settings, Network, I see my network but it keeps cycling:

"Searching", "connecting", "connected, no internet", pauses, "saving". then it starts over again.

All I have to do is restart the phone and when it comes on the internet is back and "Connected".

Like I said, it seems like a daily event but not at the same time or anything.

 

Oh, when it says "connected no internet", the wifi internet is fine on all my other devices like my windows tablet, wife's iPad, wife's iPhone, and windows desktop.

 

It seems like this phone is having more problems every day.  I may send it back under warrentee.

Talent
Message 6 of 107
13,821 Views
Message 6 of 107

Re: Wifi connection problem

Oh, I forgot to say, when I do the restart, then I have to go and disable Trusted Agents, restart the phone again, then renable Trusted Agents so I can be frustrated again that Trusted Places doesn't work.

Regular
Message 7 of 107
13,807 Views
Message 7 of 107

Re: Wifi connection problem

I have this same exact issue and people on other forums report the same, the wifi suddenly can't connect and keeps dropping. It's really annoying because it keeps happening in very inconvenient situations making the phone pretty much unusable. 

 

Please hurry up and fix it or give us a solution. 

Talent
Message 8 of 107
13,764 Views
Message 8 of 107

Re: Wifi connection problem

They said it's google's problem causing this. So we need to wait for google to solve it. 

Regular
Message 9 of 107
13,756 Views
Message 9 of 107

Re: Wifi connection problem

How is this connected to Google at all?

You can change the "Network rating provider" from "Google" to "None" and the problem persists.

Enthusiast
Message 10 of 107
13,739 Views
Message 10 of 107

Re: Wifi connection problem

Wow, it's crazy that Sony still had not fixed this issue. I came in here because I was thinking of getting this compact model and looks like it had the exact same issue as my XZ Premium. Which I had send in to Sony service center again due to this issue.

 

I looked at the other model's thread and it seems like this Wi-Fi issue affects XZ Premium, XZ1 and XZ1 Compact. Exactly same symptom....

So far no report of this WiFi issue for XZ2 and XZ2 Compact yet though...however it's touchscreen isn't precise...so...what's wrong with you? Sony?

 

What these 3 models had in common is SD835, however for XZ Premium, this issue had persisted since Android 7.1.1 so it does not look like Google's problem.

 

I had actually switched to Google Pixel 2 XL and this model completely had no such issue since day 1.

Also, all my past Xperia's from V, Z, Z1, Z2, Z3, Z3+, Z5, XZ had no such issue, all my other wifi device do not have this issue as well so it is also not my router issue.

 

This is unacceptable Sony...