account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Weird frozen display glitch after Pie upgrade

Rookie
Message 1 of 7
592 Views
Message 1 of 7

Weird frozen display glitch after Pie upgrade

After upgrading my phone to the 47.2.A.4.45 build, I'm experiencing a very specific glitch. These are the steps to reproduce it:

  • disable the screen lock (it must be set to "None");
  • lock the phone and then unlock it;
  • lock and unlock it again.

The display then gets completely frozen (except for the notification bar): whatever app I was using appears unresponsive, and if it was a browser, its content gets all black (tested on Chrome and Firefox).

The only ways to unfreeze the display are:

  • open any notification;
  • open the Settings app from the notification drawer;
  • press Apps (or Home, if you're not within the app drawer).

The weirdest part of this glitch is that, as I mentioned before, the apps themselves are not actually frozen, they just look like it. This can be proven by using whatever app has some scrollable content (e.g. Facebook):

  • check whatever content the app is showing at the moment;
  • lock and unlock the phone twice (to trigger the glitch);
  • try scrolling down (any new content won't show up);
  • press Apps and then Back.

When the app gets displayed again, you will notice that it's showing the new content (e.g. new posts): you were actually scrolling down within the app, it was just the display that looked unresponsive!

This gets incredibly annoying when I'm checking for any new notifications or what time is it, because after I've checked the phone twice and then I have to check something else, the app drawer "gets unresponsive" and I have to press Apps and then Back every time (since you're already within the app drawer, pressing Home does nothing).

I mentioned earlier that the glitch happens only when there's no screen lock. By setting up swipe, PIN, fingerprint scanner, etc. the glitch doesn't occur, but I don't think I'll ever get used to swipe to unlock the phone...

And by the way, I went through safe mode, a hard reset, and also software repair via Xperia PC Companion (which restored Pie, not Oreo), but the glitch is still there.

Is anyone else able to reproduce it? Or is there something wrong with my phone?

Thanks in advance.

6 REPLIES 6
Adept
Message 2 of 7
536 Views
Message 2 of 7

Re: Weird frozen display glitch after Pie upgrade

Hi, same here.

Except that I the lockscreen is enabled and it only happens with Chrome.

I get a black screen every 2 or 3 unlocks.

Visitor
Message 3 of 7
513 Views
Message 3 of 7

Re: Weird frozen display glitch after Pie upgrade

I have the same problem - it worked fine under Oreo.

 

Sony, when is this going to get fixed?

Rookie
Message 4 of 7
499 Views
Message 4 of 7

Re: Weird frozen display glitch after Pie upgrade

Hey, rhayy, and when it does freeze, did you try to scroll, lock and unlock again? Did the page actually scroll or Chrome just got unresponsive?

Adept
Message 5 of 7
440 Views
Message 5 of 7

Re: Weird frozen display glitch after Pie upgrade

Actually, the phone doesn't freeze. I just get black screens. 

But the phone is still responsive under black screens. I can scroll or switch apps. 

Adept
Message 6 of 7
313 Views
Message 6 of 7

Re: Weird frozen display glitch after Pie upgrade

Issue not fixed with the update 47.2.A.10.28
Message 7 of 7
302 Views
Message 7 of 7

Re: Weird frozen display glitch after Pie upgrade

I have an XZ1 and I have the same problem and its very annoying.  It started as soon as I upgraded to Pie.  I have seen other posts from people that have a XZ1, XZ1 compact, or XZ Premium experiencing the same issue.

One of the posts actually has a link to a youtube clip showing the problem:

https://talk.sonymobile.com/t5/Xperia-XZ-Premium/Phone-won-t-swipe-between-home-screens/m-p/1363607#...

 

The really annoying thing is that I have yet to see Sony acknowlege the problem let alone address it.