account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Slow wifi since system update

Learner
Message 1 of 30
4,376 Views
Message 1 of 30

Slow wifi since system update

Since I did a system update this week my WiFi Internet connection is running extremely slowly on xz1. When first connected it works fine and then it starts running extremely slowly. 

Device is working fine when connected to 4G and WiFi is working fine on other devices in the house. Any suggestions please? 

29 REPLIES 29
Emperor
Message 2 of 30
4,344 Views
Message 2 of 30

Re: Slow wifi since system update

@GBH1

 

Could you test the device in safe mode just to see if it's a third party causing this, also are you autobacking up pictures, videos with any service? 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Learner
Message 3 of 30
4,344 Views
Message 3 of 30

Re: Slow wifi since system update

Thanks for the suggestion - I'm not autobacking up pictures etc but tried the safe mode idea. WiFi seemed to be a lot better in safe mode. Is there any way of identifying which third party may be causing it? 

Emperor
Message 4 of 30
4,341 Views
Message 4 of 30

Re: Slow wifi since system update

@GBH1

 

It'll be hit and miss, it has to be an app that you've installed. 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Adviser
Message 5 of 30
4,328 Views
Message 5 of 30

Re: Slow wifi since system update

Same problem. Also disconnecting issues continue. This is terrible
Emperor
Message 6 of 30
4,324 Views
Message 6 of 30

Re: Slow wifi since system update

@newflesh

 

If you don't encounter this while in safe mode then it's a third party acting up, it's that simple, you could just repair the phone with XC or uninstall app by app

 

Xperia Companion (XC)

 

 

Software Repair Guide

 

 

Alternatives on How to backup Xperias

 

http://talk.sonymobile.com/thread/36355




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Message 7 of 30
4,257 Views
Message 7 of 30

Re: Slow wifi since system update

I have the same problem with new Security Update (build #47.1.A.12.34) on my Sony XPERIA XZ1C yesterday, my ability to surfing the Web/using apps became sluggish because it somehow affects the WiFi on my phone. I tried repair the phone with PC companion but that didn't fixing it.

Message 8 of 30
4,215 Views
Message 8 of 30

Re: Slow wifi since system update

It would be brilliant if someone let the people behind the update know of this so they can fix it with next update. 

Inhabitant
Message 9 of 30
4,188 Views
Message 9 of 30

Re: Slow wifi since system update

I am relatively speaking "new" to the Android "ecosystem"...

 

It is MADDENING to see all the bugs and fingerpointing with Android and its apps!  Nobody is accountable with Android. Do you blame the phone manufacturer? do you blame Google? do you blame the big name app developer? do you blame Linus Torvalds? do you blame the carrier? do you blame some chipset manufacturer? do you blame Amazon for putting their ads on the lockscreen? You need a PhD and linux kernel experience to truly diagnose anything, and my current experience across 3 different devices all exhibit different, critical bugs (failing alarm clocks, anyone?)

 

And all we get are these weak "community support" forums (with all due respect, everyone), rather than having some real support structures in place.

 

PS - Sony, could you PLEASE fix the distorted camera bug for the USA models?! You fixed it for the rest of the world months ago.  Are you just waiting to finish certifying the T-Mobile stuff??  Please just throw us a bone here with an ETA because you are not showing any love for the USA, and that was a fatal flaw for some other, former, manufacturers...

Enthusiast
Message 10 of 30
4,171 Views
Message 10 of 30

Re: Slow wifi since system update

In the XZ1 section is posted a solution