account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

Pop up notifications at top of screen

Rookie
Message 1 of 4
2,810 Views
Message 1 of 4

Pop up notifications at top of screen

Hello, 

 

I can't seem to be able to turn off messages that pop up over the top of other apps. If I'm using the phone as a sat nav and I get a private message every one sees it. Can you help? In the last phone I had it was a setting in app notifications but I can't find it. 

 

Thanks

 

3 REPLIES 3
Message 2 of 4
2,794 Views
Message 2 of 4

Re: Pop up notifications at top of screen

@Neil300there's no way to completely disable all peek notifications as far as I know. you might want to try enabling Do Not Disturb (DND) mode, just make sure to go to Settings > Sound > Notifications > Do not disturb > Block visual disturbances > enable Block when screen is on. that way, when you enable DND mode, the notification banners won't be showing up.

 

there's a way to change priority of some notifications, but it's a more convoluted process and you can't do that for all apps at once, just one by one. first, you need to pull down the notification panel, and long press the cogwheel icon until it starts spinning and you feel a slight vibration. this enables you access to System UI Tuner, which can be found at the very bottom of the Settings menu. in Settings > System UI Tuner > Other > you can enable Power notification controls. once enabled, you can go to Settings > Apps, tap the app you want to disable notifications from, open Notifications, tap the turquoise A icon so that it fades to gray, and then slide the Importance slider left or right. setting the slider to the 4th dot from the left (titled "No full screen interruption or peeking") should disable any notification banners from that app.

Rookie
Message 3 of 4
2,787 Views
Message 3 of 4

Re: Pop up notifications at top of screen

That would seem to solve it but I don't have the 'other' option on the system UI tuner. Any suggestions? Screen shot attached. Thanks! Screenshot_20171004-090830.png

 

Highlighted
Adviser
Message 4 of 4
2,774 Views
Message 4 of 4

Re: Pop up notifications at top of screen