account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Ongoing wifi issues even after update to 47.1.A.12.145

Highlighted
Adviser
Message 1 of 4
1,853 Views
Message 1 of 4

Ongoing wifi issues even after update to 47.1.A.12.145

Starting a new topic again on this issue as it is clearly not yet resolved.

Sony really need to get this sorted, these are not cheap devices and the issue has been rolking on for months now.

Can everyone who is still experiencing the problem please comment, the issue needs to be kept on Sony's radar.

 

 

3 REPLIES 3
Commissioner
Message 2 of 4
1,839 Views
Message 2 of 4

Re: Ongoing wifi issues even after update to 47.1.A.12.145

Yes same ongoing issue. Either internet throughput drops to below 1mbps (even on a gigabit fibre connection which usually gives in excess of 200mbps when the wifi is working properly on the phone) or says connected but no internet which means it doesn't work at all. In both cases restarting the devices fixes it, usually for around a day before the issue returns. I've tried software restore, factory reset and so on.

 

To note - Sony don't seem interested in this or at least do not want to comment. Although I know this is a user based forum their support staff (eg. @Jonas) regularly reply to other threads but not once have responded to any of the below threads discussing the same issue:

 

 https://talk.sonymobile.com/t5/Xperia-XZ1-Compact/Wifi-connection-problem/m-p/1315030#M2773

https://talk.sonymobile.com/t5/Xperia-XZ1-Compact/wifi-problem-xz1-compact/m-p/1301712#M2335

https://talk.sonymobile.com/t5/Xperia-XZ1-Compact/XZ1C-and-other-Sony-devices-cannot-connect-to-5-GH...

https://talk.sonymobile.com/t5/Xperia-XZ1-Compact/Ongoing-wifi-issues-even-after-update-to-47-1-a-12...

https://talk.sonymobile.com/t5/Xperia-XZ1-Compact/Multiple-wifi-sources-connection-issues/m-p/128584...

https://talk.sonymobile.com/t5/Xperia-XZ1-Compact/5G-wifi-connection-issue/m-p/1263675#M103

 

At least an acknowledgement would be good that they (Sony) know it is a widespread problem and they are trying to fix - as @PeteCal mentioned in one of his posts, when he spoke to Sony support they didn't even know (or at least the support agent he spoke to) it was an issue.

Talent
Message 3 of 4
1,831 Views
Message 3 of 4

Re: Ongoing wifi issues even after update to 47.1.A.12.145

To ADMINS:

 

DO not merge or close this with the last one, because its clearly not solved as you guys marked before!!

Adviser
Message 4 of 4
1,804 Views
Message 4 of 4

Re: Ongoing wifi issues even after update to 47.1.A.12.145

To be fair to @Jonas he did contact me a month ago and ask for details from the phone, I have had no further update though despite asking for one earlier this week.