account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Charging with other cables not working...

One time poster
Message 1 of 4
1,946 Views
Message 1 of 4

Charging with other cables not working...

Hello everyone, 

 

Just got my XZ1 Compact and tried using other cables to charge my phone, which wouldn't work. Only the Sony UCB20 stock cable works to charge it. The micro usb with a usb c converter cable and a One Plus 2 Dash cable will not charge the device. Does anyone know what's the problem? This is a little inconvenient. 

3 REPLIES 3
Highlighted
Inhabitant
Message 2 of 4
1,917 Views
Message 2 of 4

Re: Charging with other cables not working...

Can't confirm, use 2 cables from different manufacturers and they work properly.

JWJ
Apprentice
Message 3 of 4
1,897 Views
Message 3 of 4

Re: Charging with other cables not working...

some here, different cables work. Are you using the same adapter? If so, try a friends cable. I found previously that bad cables result in very slow charging or no charging at all. The response differs per device.

One time poster
Message 4 of 4
499 Views
Message 4 of 4

Re: Charging with other cables not working...

I've got the same problem. My Sony data UBC20 cable (the default one that comes with the phone) broke after about 2 months which was supprising. So I had no charger and no more phone. Then I realised my Nintendo switch cable was the same, however when I plug into my phone, it would charge to 60% after a full day and then stop charging and it keeps on doing the same thing. Now it'll charge maybe 1% and then stop. I don't understand why, why is Sony doing this to me... So I ordered a new charger Sony cable.