account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

XZ Lagging a lot

Inhabitant
Message 11 of 261
5,933 Views
Message 11 of 261

Re: XZ Lagging a lot

Hi Sony,

 

You guys have to do something about this. The latest Android update is destroying RAM usage on the phone, it's completely unusable:

 

https://forum.xda-developers.com/xperia-xz/help/question-xz-duals-ram-usage-7-1-1-t3601663/post72579...

 

Since updating to 7.1.1, RAM usage is constantly spiking, I'm waiting 5 seconds to switch windows or press through menus, I have to reboot the phone at least twice a day for it to continue being usable. It's completely inoperable at the moment. I've uninstalled Apps, removed a few from cached memory and nothing is changing. It says the RAM usage is majority used by the OS.

 

Build 41.2.A.2.223

Model: F8332

 

This is meant to be a high performance phone and it's a brick right now! Hoping you get back to us soon.

Inhabitant
Message 12 of 261
5,921 Views
Message 12 of 261

Re: XZ Lagging a lot

You Summrized  i've been experiencing with this Phone am not sure if its the phone or the latest update am sufferring and the phone is still 2.5 months old, what will happen in 1 year then ?!!!

Inhabitant
Message 13 of 261
5,907 Views
Message 13 of 261

Re: XZ Lagging a lot

Yeah it's being reported in many forums to do with the latest update, so I'd expect maybe you've purchased a phone with the latest update or you've updated when you turned on the phone and set it up? Before this is it was extremely fast but once updating, it doesn't let you roll back to a previous version. So there's a lot of angry people at the moment!

My phone battery is dropping to 30% within 5 hours, I'm starting to get very angry and close to installing a custom mod unless Sony release an update or rollback soon.

 

The other issues is taking video chugs and lags, so when you go to playback the video you've recorded it skips. Can't use 4k recording anymore.

One time poster
Message 14 of 261
5,895 Views
Message 14 of 261

Re: XZ Lagging a lot

I've experienced the same issue. Turning off the battery care function makes life better but it's stil super laggy. The update murdered battery life and has made the phone essentially unusable as a daily driver. I've loved my previous Xperia phones, but this one I'll be returning.

Inhabitant
Message 15 of 261
5,842 Views
Message 15 of 261

Re: XZ Lagging a lot

Will the latest Update fix that Issue ?!!

Highlighted
Regular
Message 16 of 261
5,817 Views
Message 16 of 261

Re: XZ Lagging a lot


@KHashaBA wrote:

Will the latest Update fix that Issue ?!!


I would guess no as the latest update is a security patch (and I can't get it to install on my XZ, it always fails at the verify phase :p).

I can go for about 3-4 days before mine starts to seriously lag. When it happens CPU is always continuously very high, 90%+ (confirmed with CPU-Z) and the phone gets quite warm. It's rather difficult with Nougat to figure out which background process or apps have gone haywire since the Android team has now restricted access to the process list unless one's phone is rooted. Rebooting seems to be the only remedy since I have no idea what process is causing the problem. 

 

As I'm now unable to install the latest software update I may start looking for a new phone earlier than I planned. Too bad the XZ Premium is so freaking huge, reminds me of my Lumia 1520 Slightly smiling Face.

 

Commissioner
Message 17 of 261
5,803 Views
Message 17 of 261

Re: XZ Lagging a lot


@eelpout wrote:

@KHashaBA wrote:

Will the latest Update fix that Issue ?!!


I would guess no as the latest update is a security patch (and I can't get it to install on my XZ, it always fails at the verify phase :p).

I can go for about 3-4 days before mine starts to seriously lag. When it happens CPU is always continuously very high, 90%+ (confirmed with CPU-Z) and the phone gets quite warm. It's rather difficult with Nougat to figure out which background process or apps have gone haywire since the Android team has now restricted access to the process list unless one's phone is rooted. Rebooting seems to be the only remedy since I have no idea what process is causing the problem. 

 

As I'm now unable to install the latest software update I may start looking for a new phone earlier than I planned. Too bad the XZ Premium is so freaking huge, reminds me of my Lumia 1520 Slightly smiling Face.

 


I have to reboot my XZ on Marshmallow every four or five days but it's no hardship to do that. I can't comment on the security patch because I don't get any on MM...

Sony Xperia Support
Message 18 of 261
5,770 Views
Message 18 of 261

Re: XZ Lagging a lot

Hi everyone, sorry for the delay.

 

It seems that the issues you are facing are not all exactly the same.


If, when you tested the phone in safe mode and it was performing smoothly, then this indicates that the issue is being caused by a third party app. It is a matter of eliminating apps by uninstalling them one by one and testing after each uninstall, until you find the culprit.

 

If, while in safe mode the issue was still there, then I recommend you perform a software repair using Xperia Companion. This will re-install Android on your handset and should resolve the software issues.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Adviser
Message 19 of 261
5,708 Views
Message 19 of 261

Re: XZ Lagging a lot

 


@CameronT wrote:

Hi everyone, sorry for the delay.

 

It seems that the issues you are facing are not all exactly the same.


If, when you tested the phone in safe mode and it was performing smoothly, then this indicates that the issue is being caused by a third party app. It is a matter of eliminating apps by uninstalling them one by one and testing after each uninstall, until you find the culprit.

 

If, while in safe mode the issue was still there, then I recommend you perform a software repair using Xperia Companion. This will re-install Android on your handset and should resolve the software issues.



Hi Cameron

 

Using the XZ in safe mode is not a long-term solution. In any case, third-party apps that are starting to crash/hang/lag on Android 7.1.1 have not done so on older Android versions. 

 

I've had problems with my XZ since May, when there was an Xperia/Android update released (I don't remember which now). I've since done 2 factory resets, 1 software repair (with XC) and lost count how many times I've reinstalled apps. None of these have resolved the issues with lag/crash. Now, I even need to restart my phone daily in order to get apps to work properly. It's honestly not how I imagined enjoying my XZ, especially after looking forward to it for months. 

 

Is it possible to downgrade Android from 7.1.1 (current) to a previous version or 6.0, until an updated version of the Android (or one that works properly) is available? Would this void my existing warranty? 

Inhabitant
Message 20 of 261
5,702 Views
Message 20 of 261

Re: XZ Lagging a lot

Hey Cameron

Safe Mode is not a final solution that U can live with ... off course the phone will work properly on the safe mode bcuz u just shut down everything ... so even if there are some issues it wont appear bcuz the ram is already unoccupied ... plus i mentioned earlier i didnt have such issues while i was on the previous phone Xperia Z2 ... i have same amount of apps, am not the kind of person who download lots of apps or Games.

something is really wrong over here ... the ram gets sucked by some internal app or by the system its self, its just sucked till there is noting to work on.

the Phone hangs for like a minute sometimes not just lagging, i have to restart it daily