account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Some apps with auto-update enabled will not update

Highlighted
Regular
Message 1 of 5
1,264 Views
Message 1 of 5

Some apps with auto-update enabled will not update

In the last couple of weeks I have been having an issue with apps not updating. If one fails, the rest do not update and I get no error messages telling me the update failed. If I try manually, then I get an error message - I think they were 910 and 963. Both resolutions were to clear the Google Play cache and data but this doesn't solve the problem. There is a workaround. The app needs to be moved from the SD card to internal memory, updated, then moved back to the card. I have had the latest firmware for some time so it is not that that has caused the issue. The SD card is fine because the same issue occurs on my wife's XZ and also my son's L2 and all 3 phone's developed this issue at the same time.

 

You Tube is one that won't update. It isn't on the SD card so updates after the cache is cleared. Other apps have to be moved to internal storage first. If one fails, the rest won't install until the cache/data is cleared again. It will attempt 3 downloads before giving up. This can be quite a laborious process if there are several apps that have not updated. 

 

I can't work out why this started all of a sudden, why it affects mostly apps on the SD card but also some that are not. Why do some update then the rest fail or is it their updating that requires the cache to be cleared before other non-SD card apps can update? Any ideas why this has suddenly started?

4 REPLIES 4
Learner
Message 2 of 5
1,186 Views
Message 2 of 5

Re: Some apps with auto-update enabled will not update

I'm also having this issue with Z5. The only solution is to move the app back to the internal storage. I have tried to format the SD card, downgrade/upgraded the Play Store, clear the cache, tested with Play Store beta version, but nothing worked.

I think it may be something on Google end. they may have changed the way apps are packaged and distributed.

One time poster
Message 3 of 5
1,107 Views
Message 3 of 5

Re: Some apps with auto-update enabled will not update

I have exactly the same problem on my XA. One minute all running smoothly then this problem arises.

I emailed Sony Support, as follows...

 

I have a Sony Xperia XA (F3111, Android vers:7.0, Build 33.3.A.1.97) that has a Kingston micro 200gb SD card fitted on which I've stored all the apps possible to keep the limited internal storage from filling-up.
Just recently, at the end of February 2019, I noticed updates to apps stored on the SD card were not updating smoothly, they were 'hanging' in Download Pending status OR they would download to 100% several times (usually three times! Weird!) and try to install but then revert to Ready for Update status, ie., back to square one.
I overcame this by moving the app to be updated back from the SD card to internal storage, downloaded & installed the update successfully then moved the app back to the SD card. Very Tedious!
Thinking there may be a problem with the SD card I replaced it with another (a Sony 64gb micro sdx) but the problem persists.
I've tried clearing out Cache, etc., from the appropriate/all apps but this has no lasting affect in resolving the matter. I've run AVG anti-virus with no problems and keep storage 'clean & tidy' with SD Maid, etc., but all to no avail.
The problem arose on Thursday 28th Feb 2019 very suddenly, almost as if an update or a timer/switch had activated, and despite my best efforts to resolve is still ever-present.
Can you help me please (?) because I'm running out of ideas. Any advice, guidance & Sony wisdom would be gratefully received.

 

Sony Support reply was, as follows...

 

We would recommend you to reset the phone software to get and software related issue fixed.

Important information before you perform a software repair:

All data will be deleted from the device when you perform a software repair. Photos, videos, music and documents stored on an external SD card are not deleted. If possible, make sure that you back up data stored on the internal storage that you want to keep before performing a software repair.
Make sure you know your Google™ account username and password. Depending on your security settings, your Xperia™ device may lock after a repair procedure. You then need to enter your Google™ account username and password in order to use the device.
If you don't remember your Google™ account username and password, you cannot unlock the device yourself. You can however try to recover your Google™ account username and password using the Google Account Recovery page at https://www.google.com/accounts/recovery/?hl=en. If you still can't reactivate your device, contact us.

To perform a software repair using a computer

Computer: If it is not already installed, download and install the Xperia™ Companion application from http://support.sonymobile.com/global-en/xperia-companion/.
Open the Xperia™ Companion application.
Under Manage your Xperia, click Software repair.
Follow the on-screen instructions, but do not connect your Xperia™ device to the computer until you're told to in the five-step instruction in the Xperia™ Companion window.
Tip: If you can’t turn off your device, before performing a software repair, force it to shut down. To shut down, press and hold down the power key and the volume up key simultaneously until the device emits three vibrations.

 

Now, that's ok BUT it assumes I have an MS Windows computer, that's what is meant when Support say 'Computer', on which to load Xperia Companion (I don't) and as far as I can tell there is no version of Companion available for iOS and....this does seem to be a sledgehammer to crack a walnut, doesn't it? Has anybody gone down the Companion 'sledgehammer' route and found it to be effective in sorting this problem?

 

I wish there was a way I could check which updates loaded onto my XA prior to this problem occurring, if I could I'd try to back-out those that loaded 24hrs immediately prior and then see if it 'fixes' the problem; is there a register somewhere in the system that will hold that information I wonder?

 

Of course, it is possible that a dodgey update may have corrupted something in the system software associated with downloading/updating to an SD card, in which case I'd have to borrow someone's MS Windows system to utilise that 'Companion Sledgehammer'.

 

Any comments anyone please? 🙂

 

Inhabitant
Message 4 of 5
1,036 Views
Message 4 of 5

Re: Some apps with auto-update enabled will not update

Yes, I get this exact same issue, as do others here:

 

https://talk.sonymobile.com/t5/Xperia-XZ/Some-apps-with-auto-update-enabled-will-not-update/td-p/136...

 

https://talk.sonymobile.com/t5/Xperia-Z5-Z5-Compact-Z5-Premium/Can-t-update-applications-in-the-Goog...

 

https://talk.sonymobile.com/t5/Xperia-X-Compact/Google-play-store-apps-not-updating-since-oreo-updat...

 

Seems like everyone who stores apps on their SD card on a Z or X range device, cannot update those apps if they have the up to date Play store.

 

I've had multiple e-mails with Sony support, and only got the usual fob-off responses. First saying that some app creators disable SD card use, then that the apps in particular probably don't work from the SD card, and then of course, to perform a repair / reset on my device...

 

This being besides the point that this is affecting ALL APPS (40+) I have on SD card, (which update fine when moved back to device), plus this affecting MULTIPLE PEOPLE AND MULTIPLE DIFFERENT DEVICES. What are the chances that ALL of our phones broke at the same time and need a reset? I've also seen this specific issue posted ONLY on the Sony forums...

 

It's obviously something has changed in the Play store with how it updates apps on the SD card, and our Sony Android needs updating to reflect that. I'm having trouble getting through the Sony Support buffer, so PLEASE contribute and keep pestering them, or try to get someone who will actually take ownership of this issue and pass it to the devs for diagnosis.

Regular
Message 5 of 5
1,029 Views
Message 5 of 5

Re: Some apps with auto-update enabled will not update

This affected 3 different Sony phones over night back in February so it DEFINITELY isn't a specific phone issue. Pretty peeved that Sony haven't acknowledged this issue 2 months later. It's a heck of a faff moving apps on and off an SD card twice a week however the split screen functionality makes it slightly easier.