account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

MicroSD card corrupted on device restart

Highlighted
Visitor
Message 1 of 1
1,455 Views
Message 1 of 1

MicroSD card corrupted on device restart

I did just make a post about mobile data connection since the Android 8.0 update.. however I have had another issue since I first purchased this phone a few months ago.. every time I restart my phone it says my MicroSD card is corrupt and needs to be "fixed".. however the " fix" is to format the card which fails at 20% every time even with a new card.. I've sort of just accepted this phone as having no expandable memory capability but since I'm here I may as well bring it up.. I have tried several different cards (currently its a 32GB Class 10), all cards have the same results.. I've also tried formatting the cards on a PC first, same results.. However I did notice that the PC also says there is a problem with the cards, but only after they have been in the phone, so the phone is damaging the cards somehow.. I've been through 3 brand new 32GB Class 10 cards, an 8GB Class 10 card and an older 4GB Class 4 card.. all get the same results and all are unusable after being in the phone (big waste of money in the end but had to be sure and check all options). So although I can accept this phone as having no expandable memory capabilities for me I would still like it to.. however this feels like a hardware issue so probably nothing I can do.. just wanted to check here and let both Sony and other users know that there is a problem that may effect other devices too.