account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

How to fix laggy XZ after updating to 7.1.1

Regular
Message 1 of 4
838 Views
Message 1 of 4

How to fix laggy XZ after updating to 7.1.1

Hi guys, 

 

After trying all these steps below, my XZ has been running quite smoothly again. Just try to see if it works for you. 

 

-Disable Google feed (Settings - Google - Search -  Your feed - then turn off Feed)

-Disable all unnecessary Google & Sony apps

-Uninstall Messenger and install Lite version instead.

 

Cheers

3 REPLIES 3
Inhabitant
Message 2 of 4
824 Views
Message 2 of 4

Re: How to fix laggy XZ after updating to 7.1.1

sorry,  deactivate or deinstall apps is not acceptable! when sony rolls out buggy updates,  that make devices very slow, i think ist the work from sony to fix this soon! 

Highlighted
Regular
Message 3 of 4
767 Views
Message 3 of 4

Re: How to fix laggy XZ after updating to 7.1.1

I agree. Sony better comes up with new update soon. This is just a temporary solution for those that cannot stand their laggy phones. At least it works for me. Cheers

Apprentice
Message 4 of 4
629 Views
Message 4 of 4

Re: How to fix laggy XZ after updating to 7.1.1

Agreed !

We cannot just buy a flagship phone, then disable all smart features.

If we planned to do it, we could buy a dump phone to save money.