account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Xperia premium dead screen

Learner
Message 1 of 3
296 Views
Message 1 of 3

Xperia premium dead screen

Got my Xperia XZ premium back in June.

Last week it suddenly froze & went dead. Pressing the on/off button,the led light was intermittently flashing a faint green light. I tried the 2 min techniques of holding down the volume rocker & on/off button but nothing happened.I put it on charge for couple of hours & tried switching it on again,...this time with success. What a relief!

However,this morn it has the same flashing green led/dead screen issue & I've put it back on charge again but so far nothing.

 

Is this a software or hardware issue?

2 REPLIES 2
Highlighted
Forum Legend
Message 2 of 3
290 Views
Message 2 of 3

Re: Xperia premium dead screen

it might be a software issue. try to charge the device again to make sure it is fully charge and perform software repair using Xperia Companion 


---------------------------------------------------------------------------
Learn to take care and troubleshoot your Device here:
Xperia Support by Sony: https://support.sonymobile.com/global-en/
Learner
Message 3 of 3
82 Views
Message 3 of 3

Re: Xperia premium dead screen

Appreciate the reply. 

Tried all the tricks to get my phone working again but no joy.

Contacted Sony & they booked a repair where they replaced the motherboard.

It was only 4 months old so only lay-out was postage. Got it back within 2 weeks & re-installed everything from scratch.