account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

XZ Premium suddenly died

Regular
Message 21 of 29
797 Views
Message 21 of 29

Re: XZ Premium suddenly died

Sony was not very clear about the actual problem. All that was said was it was a software issue. It was reset and clear upon return. It has been like brand new. It was my original phone that was returned, because it had my same screensaver screen protector on it. Like I said it did cost me $50 to get it fixed but that was by far the cheapest option that I had. And I think Sony wants to make it right because they explained it was a brand new program.

Rookie
Message 22 of 29
661 Views
Message 22 of 29

Re: XZ Premium suddenly died

Hellow bruce!
Few months before i had this same problem. It stucked when using and i restarted it. From that moment onwards i couldn't start it again. A green light is blinking like a faulty phone when pressing power button or connecting the charger. 
my local repairman said it is a CPU issue. We all know that sony has'nt make a good heat dissipation way yet in their phones. XZP's bezzel has made from nylon. 

What was your problem? 
How much did you pay as shipping fee?
How much time did they take?
How did you pay the service fee 50$? Credit card? 



 

Regular
Message 23 of 29
656 Views
Message 23 of 29

Re: XZ Premium suddenly died

I paid the$50 service charge. I was told it was bad software maybe from the android 9 update. It took about 4-5 weeks to get it back. No issues since! 

One time poster
Message 24 of 29
596 Views
Message 24 of 29

Re: XZ Premium suddenly died

Seems like a common theme here. I too have an XZ PREMIUM and yes, mine has died after about about 22 months. Had plenty of charge, took it out of my pocket and it was very hot. I'd been using it five minutes prior to that but now there is absolutely nothing. Dead as a dodo. Don't think I'll be getting a sony again! Had nothing but problems with them! Cheap and nasty parts, yet very expensive to buy!! 

One time poster
Message 25 of 29
580 Views
Message 25 of 29

Re: XZ Premium suddenly died

Did you get it fixed? mine just died last week with the same problem whenever I try to charge or start it only the green light is blinking I've tried everything but it still won't work 

Regular
Message 26 of 29
572 Views
Message 26 of 29

Re: XZ Premium suddenly died

Yes it is perfectly fixed. Contact Customer service and it will cost you $50. 

One time poster
Message 27 of 29
451 Views
Message 27 of 29

Re: XZ Premium suddenly died

The 2 min restart worked first time. The releif and sense of victory waas overwhelming! 

Adept
Message 28 of 29
437 Views
Message 28 of 29

Re: XZ Premium suddenly died

What fixed mine was bringing it to the service center and they replaced my phone's motherboard. They said it was a board problem.

One time poster
Message 29 of 29
90 Views
Message 29 of 29

Re: XZ Premium suddenly died

I had the same problem twice throughout the year, this day my XZ'P just died in the night while i was sleeping, i had 80% of the battery. The first time it happened i tried all the methods to turn on the device and non of them worked out, so, i just left the device in it's box and one week later turned on in the low battery icon, i charged the phone and then it was alive again. This time is different, it doesn't respond or vibrate like the first time, but led blinks in white, so is not an electrical issue. I will let the battery drain in hope that the phone revive like the first time it happened. Maybe is a software problem with android 9.

Some advice for anyone that experience this bug, you're definitely going to sweat it's scary the first time it happens. It's not a CPU damage (unless the phone is hot when is plugged on), it's a software bug, it worked for me letting the phone. I also experienced a very strange bug while i use the phone in direct sunlight, it's super rare and i don't know how to explain it jajaj but is very annoying.