account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

XZ Premium died after oreo update :(

SOLVED
Rookie
Message 1 of 11
1,662 Views
Message 1 of 11

XZ Premium died after oreo update :(

I had updated to oreo 4 days ago but after that the phone stuck at sony logo permanently. So as the sony support page advice, i use xperia companion to repair my phone knewing that all my data will lost Slightly frowning Face The phone died then. It doesn't charge (when i plug no led), can't power on. I have used z, z2, z3, xa ultra till now. I have never seen something like this before. Is there any solution for that or i have to go to the service?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Rookie
Message 10 of 11
2,328 Views
Message 10 of 11

Re: XZ Premium died after oreo update :(

The service solved the probem by changing the motherboard. :smileysmileythumbsup: 

But how can be something like this when upgrading to oreo? Neutral Face

Can it be because of a program that i have installed from google play? Question

or what can possibly cause such a problem ? Question

10 REPLIES 10
Visitor
Message 2 of 11
1,656 Views
Message 2 of 11

Re: XZ Premium died after oreo update :(

I have also an issue after the update... The lower speaker is kinda disconnected, I don't understand how. My phone has never fallen and is safe in a cover but after the update the volume is very low - even if it's playing music on the highest level. The lower speaker just doesn't work. Sony, will you please check on that issue? 

Sony Xperia Support
Message 3 of 11
1,625 Views
Message 3 of 11

Re: XZ Premium died after oreo update :(

Hi @gylinder, welcome to the community. I am sorry to hear about this issue. Slightly frowning Face

I recommend you try performing a forced shutdown by holding the power button and the volume up button for 15 seconds, it should vibrate 3 times. Then, remove your SD card and SIM card. Try to boot it up again.

 

If you are still experiencing the problem, then I recommend you perform a software repair using Xperia Companion. This will re-install Android and hopefully allow you to boot your phone.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Commissioner
Message 4 of 11
1,585 Views
Message 4 of 11

Re: XZ Premium died after oreo update :(

i think your battery totally dead. plug your phone to the wall charger up to 1 or 2 hour. after that you can see the led light. before that try this. press and hold power button and volume up button until the phone get vibrates. and then press the physical hard reset button on the phone near the SIM tray. after that plug your phone upto 1 or 2 hour until the led shows. then its charge normally. after that repair your phone using Xperia companion.

Rookie
Message 5 of 11
1,563 Views
Message 5 of 11

Re: XZ Premium died after oreo update :(

"Holding the power button and the volume up button for 15 seconds"  i've already try that several times. I also tried this for 2 minutes. But no vibrations. I've posted it to the service today, that's something myself can't deal with. Thanks anyway :smileysmileythumbsup:

Rookie
Message 6 of 11
1,562 Views
Message 6 of 11

Re: XZ Premium died after oreo update :(

    Hey, Kanchuka. Is there a physical hard reset button on the phone near the SIM tray in xperia XZ premium? i couldn't find something like that. I remember that one of my older xperia has such a thing. But couldn't find it on Xperia XZ Premium.

    I sent it to the service today. Thanks anyway :smileysmileythumbsup:

Sony Xperia Support
Message 7 of 11
1,533 Views
Message 7 of 11

Re: XZ Premium died after oreo update :(

@Lukas_96, you may wish to try the phone in safe mode and see if it is the same. If it is, try a software repair using Xperia Companion. If you still have no sound coming from that speaker, you might wish to contact your Local support team.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Visitor
Message 8 of 11
1,527 Views
Message 8 of 11

Re: XZ Premium died after oreo update :(

It worked again after restarting it. I have no idea what was the fault but it works like new again Slightly smiling Face 

Sony Xperia Support
Message 9 of 11
1,522 Views
Message 9 of 11

Re: XZ Premium died after oreo update :(

I am glad to hear it was an easy fix Slightly smiling Face


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Highlighted
Rookie
Message 10 of 11
2,329 Views
Message 10 of 11

Re: XZ Premium died after oreo update :(

The service solved the probem by changing the motherboard. :smileysmileythumbsup: 

But how can be something like this when upgrading to oreo? Neutral Face

Can it be because of a program that i have installed from google play? Question

or what can possibly cause such a problem ? Question