account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

XZ Premium cannot reconnect to WiFi after Oreo

Regular
Message 111 of 136
907 Views
Message 111 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

My issues seem to have gone. I reset the wifi I.e. Deleted all WiFi data and updated the software to the latest version. I also made all other WiFi networks that I connect to I.e. dashcam etc. manual selection. It also helps if you have separate SSID's for 2.4GHz and 5GHz, and don't use auto connect with one of them. And yes, I have a TP-Link Archer VR2800 router that works OK now with the phone. I know it's not ideal and occasionally I have to restart the phone, but I can live with that.

Enthusiast
Message 112 of 136
903 Views
Message 112 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

If 5Ghz network is supported by the router, there's no need to store 2.4Ghz logging data in the phone at all.  I noticed that  long time ago, when my XZP has serious difficulties connect my wifi, because 5- and 2.4Ghz networks has same ssid. After changing separate ssids and removing logging data from the ZXP, there's zero problems with wifi.

 

Adviser
Message 113 of 136
900 Views
Message 113 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

HI,

 

I updated to the recent software update it seems that it does not disconnects very often anymore.

Regular
Message 114 of 136
896 Views
Message 114 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

This is true if you are close enough to the router to be able to use the 5GHz band. In my case I use the phone out in the garden as well as the house, so 5GHz doesn't work too well. I've got mine to auto connect to 2.4GHz with my 5GHz set to manual.

Regular
Message 115 of 136
892 Views
Message 115 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

That is a very rare situation to the SSID name the same for both 2.4 and 5Ghz.

I doubt there are many people with that set-up.

 

5Ghz will not work well if your distance from the router/modem is far or obstructed by walls, furniture etc it suffers less interference and therefore preferred, however, the operating frequency means that it is a much weaker signal strength to 2.4Ghz.

Enthusiast
Message 116 of 136
886 Views
Message 116 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

I have Asus RT-AC68U router, and its wifi settings offers to copy them and make 2.4- and 5Ghz preferences identical. It's worth to XZP owners check their router settings and make changes if necessary.  My former Sony Z3+ has no problems with this setup.  Clearly the XZP has difficulties to make difference between 2.4- and 5Ghz wifi networks .

Learner
Message 117 of 136
789 Views
Message 117 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

Sir pls tell me how to change sepsepara ssids and remove logging data from XZP iam really sad

Visitor
Message 118 of 136
701 Views
Message 118 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

Remove your Sim and leave it out of the phone for 1 minute.

Pop it back in....

 

O2 support indicated that the issue was a provisioning of services on the Sim since the update.

Certainly appears to have worked for me.

 

The SIM was the only thing I thought couldnt be the cause - so the one thing I never tried :/

Highlighted
Enthusiast
Message 119 of 136
600 Views
Message 119 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

Seems Sony just cannot fix this issue.

On latest 47.1.A.12.205, Wi-Fi still disconnect itself randomly. However, the improvements this time was that you can just connect it back manually and it will stay for a while without restart.

One time poster
Message 120 of 136
580 Views
Message 120 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

sony is the biggest  ,better sell company to chinese!!!!they will know how to repair this