account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

XZ Premium cannot reconnect to WiFi after Oreo

Enthusiast
Message 101 of 136
814 Views
Message 101 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

I own both the Xperia XZ Premium and Pixel 2 XL, and no, Pixel 2 XL do not have any wifi problem....in fact I am using it as daily driver now while the Xperia XZ Premium has been with service center for 3 weeks now...

 

Some said that it is Google's problem, if that is so...how do you explain XZ and XZs which was also updated to Oreo but yet do not have this issue? And why the XZ2 and XZ2 compact still no one complaint of these issue if it is Oreo problem?

 

Anyway, just sent it in and complaint to them about this problem. I have already done so, they replaced the motherboard but doesn't work. They tested again and told me no fault found, which is very frustrating because it does have an issue when we use it. They need to know that many are having this problem, because I was surprised when Sony told me they didn't receive much complaint on this...

Regular
Message 102 of 136
808 Views
Message 102 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

Sony XZs does have the issue 

My XZs has been suffering this issue since updating to Oreo way back in December 2017....I've had to change my phone contact to unlimited data to get around it and leave wifi switched off all the time 

My battery life is better as a result ...if you look for the positive!

 

No wonder Sony is losing the mobile phone race as they produce rubbish untested software and stick their head in the sand when you notify them of the issue. They deny that it is an issue and expect you to live with a $1000 piece of junk!

 

I and my close friends will never buy Sony again.

Inhabitant
Message 103 of 136
735 Views
Message 103 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

I also have WiFi problems with an XZ1 Compact. Almost everyday I have to restart it because it drops connection and not connecting anymore(i.e. when coming home). I think it is happening often when changing connection from mobile data to router.

* It's not a router fault, this is happening with my 4 usual routers (home, office etc)

* It's not about updating or reseting or firmware restoring. I've done all that.

Enthusiast
Message 104 of 136
716 Views
Message 104 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

Are you able to update to 47.1.A.12.179 yet? 

Highlighted
Inhabitant
Message 105 of 136
707 Views
Message 105 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

"Are you able to update to 47.1.A.12.179 yet? "

I did, about 2 weeks ago.

One time poster
Message 106 of 136
693 Views
Message 106 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

My Xz premium is currently at Sony repair centre for the second time due to the same problem that I've had since March after the same update.  They haven't told me what it is.. .just that they are doing tests on it at the moment.  I've done all of the things mentioned above including restart in safe mode and after a while it gets back to normal! Really frustrated! And I just get attitude every time I call the repair centre about it. 

Regular
Message 107 of 136
687 Views
Message 107 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

I just cannot fathom why a huge company like Sony treat their customers like this unless they want to go bankrupt or are already going bankrupt and have been told to ignore customer service and just reapt sales money and run.

I now live in a different country to where I bought the phone back in July 2017. Immediately after the December 2017 update from Nougat to Oreo my phone became a paperweight and I've lived with it for 6 whole months without being able to use wifi ....crazy I know but Sony are not interested in helping me as 1) they deny all knowledge of any wifi issue 2) they say that the country I live in now cannot fix the issue of another country... the phone is actually sold here anyway! So I guess they are not like Dell with worldwide support coverage 3) they really me off as they continue to spend money to advertise their new phones at the European Championship Final game but will not support my claim for assistance whether it be to pay the salary of a technician / reimburse me for the paperweight product I now have.

Never ever buy Sony again...my whole family know it, my friends know it and hopefully potential customers now know it. 

Learner
Message 108 of 136
660 Views
Message 108 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo


@RussianOne wrote:

I actually never tried because I cannot afford running the phone in safe mode for a day or two. I understand it may be caused by third-party apps, however. 

 

The very fact that it started with Oreo update in XZ Premium and it was the case with XZ1 Compact out of the box tells me there is something wrong with the OS. 

 

Am I the only one having this issue? 


I have the same problem but it doesn't happen on all Wi-Fi networks 

One time poster
Message 109 of 136
609 Views
Message 109 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

Hi All ,
I noticed this problem lately on my XZ premium ,
I'm on 47.1.A.12.179 now , that's mean I'm on relatively new version but no clue till now.

any ideas?

Regular
Message 110 of 136
602 Views
Message 110 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

So I visit a friend house and my phone connected to his wifi and maintained connection ...wow!

So I bought the same ZTE router and now my issues have gone from home .

Previously I used TP-Link. 

The TP-Link was otherwise fine, so my XZs phone has cost me even more money to resolve this issue