account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Wifi signal dropping

SOLVED
Learner
Message 231 of 346
1,280 Views
Message 231 of 346

Re: Wifi signal dropping

Those people who have problems with the wi-fi of the phone, should try the following solution, since it worked for me. The solution is to reinstall the latest software update, but before pressing "install", it is necessary to disable the wi-fi network of the phone. was it understood? before re-installing the update, simply disable the wi-fi network of your premium xz

Visitor
Message 232 of 346
1,200 Views
Message 232 of 346

Re: Wifi signal dropping

My New Sony XZ1 Wi-Fi Problem

Issue Description

               Wi-Fi connection keeps dropping 

Issue Symptoms:

  1. First, I noticed that there is a problem in WhatsApp message sending after written a message and hit Send, the message hang and not sent for around 20 seconds! I remove the WhatsApp and reinstall it again with no hope or result.
  2. Also, I noticed the problem on Facebook and YouTube, the page loads and after few seconds it stopped loading and the images not displayed for 20 seconds
  3. The same problem happens in Google Play Store when searching, the search every now and then takes a long time and the applications small images not loaded in time.

Steps I did try to fix the issue:

Applying all steps as stated on Sony support site:

https://support.sonymobile.com/global-en/xperiaxz1/faq/my-wi-fi-connection-keeps-dropping/

Resetting the device:

After installing the latest update using Xperia system update “47.1.A.5.51” I made a factory data reset to the mobile, but unfortunately, the problem still exists.


Safe Mode:

I started the mobile in safe mode to check, but unfortunately, the problem still exists.


Change router configuration:

I doubt that the source of the problem is my router so I changed Wi-Fi encryption to different protocols with no result, also I tried to remove the security at all, but the same problem still exists.

Also, I tried to connect to my NETGEAR router using 2 frequency band settings (5 GHz and 2.4 GHz) but unfortunately the problem still exists.

Changing the router:

I replaced my router “NETGEAR Nighthawk R6700-100NAS AC1750 Smart Dual Band Wi-Fi Gigabit Router” with my D-Link router(DSL-2730U) but the problem still happens.

 

@Sony , what should I do ?! as you know the WiFi is an important feature? right ??!!

Enthusiast
Message 233 of 346
1,187 Views
Message 233 of 346

Re: Wifi signal dropping

For all those who are sufering from WiFi connection isssue, let's identify the condition that problem occurs.

 

I've seem several reports this issue happens only when BOTH mobile data and Wifi is on.

So can you all check this and report here?

 

If this is true, we can confidently say it has nothing to do with router side but device/OS rooted.

 

 

Learner
Message 234 of 346
1,179 Views
Message 234 of 346

Re: Wifi signal dropping

I recently purchased the XZP when my LG V10 decided to expire on me. I game on phones quite abit (Vainglory) so when I tested the XZP on the said game, I get sudden latency spikes in-game when I am playing from my home wi-fi. I read somewhere else to disable mobile data when wifi is connected. I tried this one time the other day and it disconnected my game fully before re-connecting back to wifi. 

 

To my understanding, this is quite unusual. Even on my V10 when I was having both wifi and mobile data (LTE) enabled, whenever I'm in-game and disconnected the mobile data, I have always stayed connected. I would only get disconnected from the game if I'm doing it the other way round (i.e. disconnect wifi to switch to LTE). Hence the wifi connection of the XZP is somewhat buggy in my opinion.

 

Also, I'm still getting random latency issues even with just wifi connection for the game, which is pretty much absent on the LG unless there are reports of server issues with the said game.

Regular
Message 235 of 346
1,161 Views
Message 235 of 346

Re: Wifi signal dropping

I still have that dropping issue too!

Thats what my connection looks like.xzpwifiissue.png

 

It cant be that on a 700€ phone this necessary function dont work...

One time poster
Message 236 of 346
1,100 Views
Message 236 of 346

Re: Wifi signal dropping

SAME ISSUE.

 

I don't have 5Ghz routers.

 

But all my 2.4Ghz routers disappear, various manufacturers. Tenda, TP-Links, Mikrotik (I have these in my house).  Different software, bands or channels doesn't seem to make a difference. 

 

Regret this phone so badly at this point.

Message 237 of 346
1,092 Views
Message 237 of 346

Re: Wifi signal dropping

As I said before...several times...if you do a search on the internet for "WiFi drops with Oreo" you will see that this is an ongoing Google Android problem affecting many different cell phones...even Pixel's!

 

So you can switch phones and find yourself with the same issue all over again. It is the luck of the draw as far as I can tell. Mine works without issue and I never did any factory reset, or software repair since receiving the phone. I never do unless their is a major problem.

Enthusiast
Message 238 of 346
1,059 Views
Message 238 of 346

Re: Wifi signal dropping

My Wifi connection stabilized after I turned on Bluetooth on.

 

I know it sounds counter-intuitive, and I'm still observing.

 

Can someone try this too?

Message 239 of 346
1,055 Views
Message 239 of 346

Re: Wifi signal dropping

Turning on Bluetooth hasn't helped me it actually gave me loads more trouble since the update I got yesterday, the update was a firmware update of Android Oreo. 

 

Regardless, turning on Bluetooth made my device "Freeze" and "lag" even simple stuff as being on the homescreen freezes the device.

 

Though what helped me was as someone has probably mentioned before, turning off everything and then updating to Oreo from Nougat,  you may try a firm flash or downgrade can be an option too.

 

Hope that gives you an idea, though I have to fix the lags via the sda at the boot menu options.

Inhabitant
Message 240 of 346
1,034 Views
Message 240 of 346

Re: Wifi signal dropping

I also have this issue on 47.1.A.5.51, when turning on Wi-Fi while airplane mode is on, wifi can't connect but with airplane mode disable, it can.