account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

Multiple problems with the XZ Premium

SOLVED
Regular
Message 1 of 14
4,460 Views
Message 1 of 14

Multiple problems with the XZ Premium

These are some minor issues I've found are affecting my device (my phone is in Croatian so most of the phone messages are roughly translated):

 

  • When trying to resume a paused song with the button on my headphones, the first press, which is supposed to resume it, does nothing, whereas the second press plays a fraction of a second of the song then immediately pauses it, as it is only the third press of the button that resumes the song. This is not a headphone-specific issue as I've had the same problem on my previous Sony phone, the Xperia Z1, and the problem can be replicated on both devices, with multiple headphones, including the ones I got in the box along with the phone.
  • When trying to swipe away the Music app's widget in the notification bar, (when a song is paused), the first swipe sometimes reveals the settings button on the left or doesn't reveal anything at all, but simply pushes the widget a bit to the right then returns it back to its place. Only after 2-4 swipes does the widget completely go away. The same thing happens regardless of whether the phone is locked (swiping the notification widget on the locked screen gives the same result), unlocked, with/without headphones plugged in. The same problem arises when swiping the widget to the other side.
  • When in the Music app, if I open an artist's music collection or an album, then enlarge the currently playing song window, pressing the Back button will bring me back to the default homepage of the Music app instead of returning me to the artist/album page I was viewing before checking the screen of the currently playing song.
  • The "smart charging" notification is **bleep** RELENTLESS. Like, I get it, I have that option turned on, now stop molesting me with reminders almost every time I plug in the charger.
  • The Applications option in Settings is a bit laggy. The phone is insanely fast (no stuttering whatsoever on any other occassion, I even compared the same functions with an iPhone 7 and a Galaxy S8 and every segment of the OS is faster with the XZP), but the Applications option is slow when loading. I can let each app in the list load, but when I scroll back to the top then scrolling down once more, it will start loading the app list yet again (takes 3-4 seconds to load the list; I have 75 apps listed under the Installed category in the Play Store (including some Sony and Google apps).
  • The fingerprint scanner sometimes doesn't recognize the fingerprint after multiple consecutive tries and comes up with the "Too many attempts, try again later" message so I have to unlock the screen with the 4-digit PIN. Mostly it's when my finger is wet or something, but sometimes this happens when my finger is squeaky clean and dry, as is the scanner. After locking the screen, wiping the scanner and my finger completely dry (even though they already are), the scanner works again. Maybe worth looking into.
  • Last month I managed to spend all my GB that I have under contract (after which access to mobile internet is restricted) and whenever I wasn't connected to a Wi-Fi network, I'd have a notification saying "Connect to network: HT HR". HT HR is my service provider, and clicking it leads me to the provider's website showing me my net usage statistics. Is there a way to disable this alert? Long press on the alert only gives me the options "Don't block" and "Show only logo of notification". I can swipe away the alert, but it reappears after connecting then disconnecting from a Wi-Fi network.
  • Sometimes, when checking the "My Apps & Games" category in the Play Store, the app will check for updates indefinitely and won't list the recently updated apps. Restarting the phone fixes this, but I haven't tried clearing the app data, and I think one time the problem was fixed after checking again after half a day, without restarting the phone. This is definitely not a network-related error, so maybe you all could check into that too.
  • When I'm waiting for the bus at my usual bus station, I can find the city's free Wi-Fi or the eduroam netowrk and connect to either of them without a hassle (all bars filled when connected), but after maybe 5-10 minutes I suddenly (literally while scrolling on Chrome or checking Facebook) get disconnected and neither of the connections won't show up anymore under available Wi-Fi networks. Obviously, I wouldn't be complaining if I moved away for a few meters or anything like that, but I'll always be standing in the same place or even sitting, but it just disconnects me after 5-10 minutes and the connection disappears. If I go to a nearby store and connect to their network then go back to the same position after a few minutes, the 2 networks sometimes (rarely) reappear. Disabling and reenabling Wi-Fi does nothing and neither does restarting the phone, as I tried both of those. I haven't encountered any other network problems when at home/work/college/visiting friends or family, but this is particularly making me curious as my friend doesn't seem to have any problems with either of the networks on his phone. I would've thrown this under "unreliable open network" but as I've been reading up on the Wi-Fi problems other people were having, I'd certainly have a deep look into this if I were yall.
  • The brightness flickering/alternating/whateveryoucallit-ing. Most people have been reporting the brightness flickering is happening when the screen is at full brightness, and I think that may be the case with my unit too, but I think the problem appeared a few times when the phone was on around 80-90% brightness. Returning the brightness to 60-70% fixes it, then I can go back to 100% and the flickering is gone. I've had this problem 8-10 times in exactly 3 months. Tolerable, but annoying and ruins the user experience.

I know this is a giant wall of text and probably a nightmare for whoever is paid to read this crap, but I'd really like it if this stuff was taken care of, no matter how trivial it all may seem, considering the more serious problems some other users are reporting. The phone is near goddamn flawless, but some of these issues really ruin the complete experience. I'll let you all know if I run into anything else.

 

If anyone has run into the same problems, please let me know by commenting here, and if you found a fix to any of these, obviously I'd greatly appreciate it if you shared your valued findings with us. 

 

If there's a more appropriate place for me to report this stuff, also kindly let me know.

 

Thank you in advance for your understanding and response!

 

Kindest regards,

 

LL

Sony Xperia XZ Premium, Android 8, HT HR
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Message 2 of 14
7,982 Views
Message 2 of 14

Re: Multiple problems with the XZ Premium

@Rihabelye

 

regarding headphone button - sometimes it takes a while for the "resume playback" command to come in effect (especially if music has been paused for some time) and I guess that's what happens here. you press the headset button, and before the music starts playing, you press the button again which pauses playback.

 

re: Music app - you might want to post your issues in the official Google+ group here https://plus.google.com/communities/102950480733956864546

 

Play Store checking for updates indefinitely is a Google Play Store app issue, and I've read about it happening on other OEMs' phones too. so far the only fix I've found when it happens is to clear Play Store cache.

 

I guess the reason the Settings > Apps list is laggy (it happens here too) is because not only the phone is listing all the apps on the device, it's also calculating space occupied by each and everyone of them. I don't think there's anything that can be done about it.

 

Battery Care - if you mean the pop up appearing when you plug in the charger, there's a checkbox to never show it again. if you mean the actual notification, then I guess it's here to stay. if it was gone, there wouldn't be any way to tell if it's actually enabled or not. it also tells you estimated time of the battery reaching full charge, AND provides the way to disable Battery Care if for some reason you need a quick top-up.

 

WiFi reliability has been improved in the latest update, with build number 45.0.A.7.137. you can check your software version in Settings > About phone.

 

I've never had my phone's screen flicker, but I know some people thought their display was acting up when they've noticed Qualcomm Assertive Display kicking in https://www.qualcomm.com/news/onq/2015/02/20/assertive-display-power-efficient-technology-thats-easy... perhaps that's what you're noticing? in bright environment the display changes its contrast in order to make the display more readable.

13 REPLIES 13
Highlighted
Message 2 of 14
7,983 Views
Message 2 of 14

Re: Multiple problems with the XZ Premium

@Rihabelye

 

regarding headphone button - sometimes it takes a while for the "resume playback" command to come in effect (especially if music has been paused for some time) and I guess that's what happens here. you press the headset button, and before the music starts playing, you press the button again which pauses playback.

 

re: Music app - you might want to post your issues in the official Google+ group here https://plus.google.com/communities/102950480733956864546

 

Play Store checking for updates indefinitely is a Google Play Store app issue, and I've read about it happening on other OEMs' phones too. so far the only fix I've found when it happens is to clear Play Store cache.

 

I guess the reason the Settings > Apps list is laggy (it happens here too) is because not only the phone is listing all the apps on the device, it's also calculating space occupied by each and everyone of them. I don't think there's anything that can be done about it.

 

Battery Care - if you mean the pop up appearing when you plug in the charger, there's a checkbox to never show it again. if you mean the actual notification, then I guess it's here to stay. if it was gone, there wouldn't be any way to tell if it's actually enabled or not. it also tells you estimated time of the battery reaching full charge, AND provides the way to disable Battery Care if for some reason you need a quick top-up.

 

WiFi reliability has been improved in the latest update, with build number 45.0.A.7.137. you can check your software version in Settings > About phone.

 

I've never had my phone's screen flicker, but I know some people thought their display was acting up when they've noticed Qualcomm Assertive Display kicking in https://www.qualcomm.com/news/onq/2015/02/20/assertive-display-power-efficient-technology-thats-easy... perhaps that's what you're noticing? in bright environment the display changes its contrast in order to make the display more readable.

Regular
Message 3 of 14
4,432 Views
Message 3 of 14

Re: Multiple problems with the XZ Premium

@najodleglejszy

 

Thanks for the all-encompassing reply.

 

I don't think the problem with the headphones is me pressing the pause button as soon as the phone is about to start playing the song, because sometimes I've tried waiting for up to a minute after having pressed the headphones button to resume and still nothing plays until I press it the second time (pause). However, I will post this in the Music app's Google+ page and see what they have to say (maybe it's even phone-related since I haven't tried other music players).

 

The screen flickering answer does potentially explain what's happening, but it still is no valid excuse. I mean it sounds logical when you spin it like that, but in reality it looks quite ridiculous when the screen changes brightness 3 times per second. There should certainly be a software workaround that would limit the Assertive Display sensitivity or whatever (not familiar with the details whatsoever).

 

Further Wi-Fi improvements and a fix for the display issue are definitely some things I'd consider essential on the to-do list, possibly for the very next update.

 

Thank you again for the reply.

Sony Xperia XZ Premium, Android 8, HT HR
Apprentice
Message 4 of 14
4,421 Views
Message 4 of 14

Re: Multiple problems with the XZ Premium

Pozdrav komšija,

my phone is almost dead, nothing works properly, tried everything, keeps crashing.. If you know a solution let me know.. Slightly smiling Face 

Message 5 of 14
4,388 Views
Message 5 of 14

Re: Multiple problems with the XZ Premium

What app do you use to play music? I find the built in music app kinda buggy. I cannot increase/decrease volume if i am using bluetooth.

 

And as for the swiping away from notifications, i get that too so i guess its normal.

 

I know what you mean opening Applications is slow in settings. Yes it does stutter on my XZP too but when i scroll nothing needs to reload. 

 

For google play updates. Just try by closing the app(recent apps button and swipe it away) and opening it again. Works for me. 

 

And the fingerprint scanner is like that on mine too. I have sweaty hands so yeah we on the same boat. I have that issue on most phones except on the Mi6 as they have a better sensor bla bla. 



Sony XZ Premium,Samsung S9 Plus and iPhone X.
MDR-Z1R,ATH-MSR7 and V-Moda Crossfade Wireless.
Regular
Message 6 of 14
4,138 Views
Message 6 of 14

The disappointment in this phone is evergrowing

Reading the topics that are being created here daily, I really can't help but wonder what the point of this forum actually is.

 

Day by day, there is a worrying increase of various problems and bugs that users are running into while using their XZ Premium. Paradoxically, this phenomena is at a recurrence increase with each new firmware update.

 

A brief list of issues that haven't been fixed and have barely been addressed by official Sony Mobile staff, or haven't been addressed at all, as of October 26, 4 and a half months since the release of the phone and 4 days since the latest firmware update, Android Oreo:

 

  • ToF and RGBC sensors not working since the Oreo update
  • 3D Creator not working properly since the Oreo update
  • Problems with phone calls since the Android Oreo update
  • Qualcomm Assertive Display causing embarrassing display brightness oscillations since the release and nothing has been done
  • Touch responsiveness, accuracy and speed is unbelievably, abhorrently bad since the release, especially noticeable when typing
  • extremely unstable and unreliable Wi-Fi connections since the release and this hasn't been fixed with one of the previous updates even though it was listed as fixed in the changelog
  • No Treble implemented into the Android Oreo update even though it was mentioned and promised in the promo visuals for the XZ Premium Android Oreo update.

 

As infuriating as the seemingly endless and evolving list of issues that have basically become a signature and synonym for Sony Mobile, is the lack of feedback and support by the official Sony Mobile staff that is undoubtedly reading most of the threads and replies that are posted here. Reading into it even more, you will come to realize that the only problem that has been fixed so far is the camera distortion issue, and only so after relentless banter from the disappointed and annoyed users. Every other problem is, for no fathomable reason, being swept under the rug.

 

To make matters worse, the handful of users that actually do take their time to reply to threads and "help" with reported issues, never go any further than recommending a factory reset, starting safe mode or clearing the phone cache. Not only that, but most users here lash out on any other user reporting issues, saying that they are being petty and shouldn't complain about anything so "insignificant". Blaming clearly widespread problems on a faulty unit argument does not do any good for the brand, the device's legacy and reputation or the users' satisfaction with the device.

 

I'm so sad that a phone with so much potential is being ruined this way and it's safe to say that this is my last Sony phone ever. Unfortunately, Sony already got my $500 and I'll have to do with what I got for that much money, but this is just depressing. I hope things change for the better.

Sony Xperia XZ Premium, Android 8, HT HR
Regular
Message 7 of 14
4,118 Views
Message 7 of 14

Re: The disappointment in this phone is evergrowing

And congratulations to whomever moved my thread and made it a reply to an old thread, you're doing a really great job at keeping shush anyone who has anything bad to say against Sony.

Sony Xperia XZ Premium, Android 8, HT HR
Emperor
Message 8 of 14
4,113 Views
Message 8 of 14

Re: The disappointment in this phone is evergrowing

@Rihabelye

 

No one is trying to hide anything, you have an ongoing thread on this topic, I've merged your posts. 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

One time poster
Message 9 of 14
3,309 Views
Message 9 of 14

Re: The disappointment in this phone is evergrowing

I have had this phone little over a week and I am contemplating returning the phone and going to another make. 

Every day I have to restart the phone since update. 

Fingerprint scanner won't work half the time, camera keeps crashing, apps won't respond, Bluetooth turns itself off and won't turn back on unless I restart the phone, when I tap on something to write like on this post the keyboard comes up but then you can't see what your writing unless you back up and press again to write. 

I have had the z1 z3 z5 premium and the xz1 premium, this has got to have been the worst for faults I have had.

Very dissatisfied with it and the keyboard missing out letters when you press them is really getting annoying, this post has been a nightmare to write 

Message 10 of 14
3,301 Views
Message 10 of 14

Re: The disappointment in this phone is evergrowing

@Angrywelshbear I'm not having any of those issues on my XZP. see if you're having the same issues in safe mode to rule out a third party app causing them. if the issues persist in safe mode, you might consider performing a software repair using Xperia Companion.