account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Charging my phone doesn't seem to work properly

SOLVED
Adviser
Message 1 of 14
905 Views
Message 1 of 14

Charging my phone doesn't seem to work properly

The Xperia XZ Premium comes with a quick charger 3.0 and a typ c usb cable, so all that means that the phone should get charged fast, correct? 

 

Well, it takes me to charge it from 50% to 100% two hours, which can't be right at all. The charging process gets EXTREMELY slow once it reaches 80%, but that could be just a throttling implemented by Sony, dunno.

 

Regardless, I have tested the original charger and another one from Amazon; same result. I've charged with the phone being off and on by the way. So, the phone itself has a defect? Battery performance is very good and it doesn't get hot at all, though.

1 ACCEPTED SOLUTION

Accepted Solutions
Adviser
Message 11 of 14
1,145 Views
Message 11 of 14

Re: Charging my phone doesn't seem to work properly

Nice to see a fellow German guy! Anyway, yes, it is indeed a quick charger, for I just called the customer support and they confirmed it. According to that gentleman, it'll take maybe a week or something until that charger starts charging faster; in the beginning, it's all about getting used to and stuff. 

 

That it gets very slow starting from 80℅ is also normal; that's a precaution thing, so the battery won't get damaged etc. It does charge fast when the battery percentage is very low, yeah.

 

To the other guy: there is no notification when using a quick charger; it's a Sony thing.

View solution in original post

13 REPLIES 13
Adviser
Message 2 of 14
897 Views
Message 2 of 14

Re: Charging my phone doesn't seem to work properly

Things I have done: restarted the phone, tried out several power outlets, changed the cables and used another charger. From 30% to 100%, it takes me like 2 hours and 20 minutes. 

 

 

Message 3 of 14
895 Views
Message 3 of 14

Re: Charging my phone doesn't seem to work properly

have you tried using another **cable**? I've read that some type C cables have better charging rates than others (edit: I didn't notice the reply you've posted about trying different cables, my bad)

 

the throttling near 80% can indeed be Sony's doing, as the phone is supposed to "learn" at what time do you plug your phone or take it off the charger, and charge it fast until 80-90%, and then slowly go to 100% right before the time you usually take it off the charger.

Adviser
Message 4 of 14
890 Views
Message 4 of 14

Re: Charging my phone doesn't seem to work properly

Thanks for having taken the time to read through my long posts. There is an option which you can enable or disable: the battery care thingy; I have turned that off and on prior to charging my phone.

 

How is it with your phone? Maybe tell me how long it takes you to charge it completely, so I can know if that's normal or not. I mean, 2 hours for 50% is ridiculously long and there is nothing "quick" about that. My V10 and G6 charge WAY faster than that and they have quick chargers 2.0.

 

My phone seems to be faulty *sighs*

Message 5 of 14
887 Views
Message 5 of 14

Re: Charging my phone doesn't seem to work properly

sorry, I only have the X, not XZ Premium, so my experience wouldn't be much relevant here.
Adviser
Message 6 of 14
886 Views
Message 6 of 14

Re: Charging my phone doesn't seem to work properly

That's a bummer, but thanks anyway. I hope someone else can help me out, then.

Adept
Message 7 of 14
884 Views
Message 7 of 14

Re: Charging my phone doesn't seem to work properly

Would you mind checking the model number of the charger that came with the XZ?

 

Actually I am also still with the X here and didn't get my XZ yet, but from what I have 

read about it and seen in some reviews, it actually doesn't come with a quick charger, 

but only a normal charger. The quick charger would have to be bought separately.

 

I am not sure if Sony maybe changed their mind and sold some of the devices with 

quick chargers, which would be definitely nice considering it's a "premium" device, 

but my initial guess would be, that it is just a usual charger and that's why it might 

take so long to charge.

 

I just double checked and watched some reviews and unboxing videos again.

The XZ Premium comes bundled with the "UCH 20" charger (same charger that 

came with the X already), which is NOT a quick charger.

The quick charger for the XZ Premium should be the "UCH 12W":

https://www.sonymobile.com/global-en/products/accessories/quick-charger-uch12w/

 

2017-06-14 17_22_26-Mobile Accessories from Xperia™ - Sony Mobile (Global UK English).png

Adviser
Message 8 of 14
874 Views
Message 8 of 14

Re: Charging my phone doesn't seem to work properly

Sure thing. It's worth mentioning that I have the German model, so it's possible that the letters and numbers might not make much sense to you:

 

Charger UCH 12 1300-7137.1

Input: 100-240V ~ 400mA 50-60Hz

Output 5.0V=2700mA

              9.0V=1800mA

              12.0V=13500mA

Typ: AC 0051 EU

S/N: 4017W18400061 SEM0900

 

I wasn't sure what to type, so I just listed everything. Anyway, the charger has that lightning icon with a 3 next to it, so it must be right. Besides, my Amazon charger is also slow with it and that definitely is a quick charger 3.0

Highlighted
Adept
Message 9 of 14
870 Views
Message 9 of 14

Re: Charging my phone doesn't seem to work properly

Well, that actually brings us back to the beginning again, as the UCH 12 definitely IS a quick charger.

Funny to see that it comes with the UCH 12 in Germany (which gives me hope as I am in Germany, too), 

but still comes with the UCH 20 in other countries.

 

But if it's really the UCH 12 and the original cable that you're using, 

it should definitely charge faster. I am not sure about the 50-100% charging part, 

but at least in the low battery percentage it should charge quickly up to an amount 

that will give you enough power for a while. I actually don't know how the battery 

management handles quick charging. 

Did you ever give it a try to empty the battery to 1-5% and then connect to the charger?

Does that give you a faster charging at least up to 50%?

Adviser
Message 10 of 14
864 Views
Message 10 of 14

Re: Charging my phone doesn't seem to work properly

I have never seen "charging rapidly" come up either. It does seem to take a few hours to charge for me too. How long should a QC3 take to charge from 10% to 90%?