account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Proximity sensor issue during call

Inhabitant
Message 31 of 56
1,469 Views
Message 31 of 56

Re: Proximity sensor issue during call

I couldn't hang up just now. Just a black screen. Have sony acknowledged the problem or do I take it back for repair? 

Adviser
Message 32 of 56
1,463 Views
Message 32 of 56

Re: Proximity sensor issue during call

Please contact your local support. When I did this they said they hear about the issue first time. We all must generate as much as possible complaints to official support. Then probably we could hope for fix with next update. I don't think they react on this forum.

Message 33 of 56
1,446 Views
Message 33 of 56

Re: Proximity sensor issue during call

Man its harder to say... the forum its about this! they need to see it! last week i have send an email to sony about the issues and updates on the XA2, first reply the copy&paste thing about "make a hard reset blabla or reinstall software with sony app) men i say look the forums and see the problem. they reply again with a almost the same copy &paste, i say it stop that copy paste and give a real answer about my problem and all the plp on the forum, u guys know about this or are working on it? and  they again reply me with the same!  and again, i mean i have like 7 emails from the "support" and all the msgs its almost the same message "make the hard resets or software recovery blabla, sony dont make the updates for the phones, its google and bla bla bla" im not new in this and thats bulls.... guess this is my first and last Xperia Phone, they dint care about their customers and the support its zero!

Inhabitant
Message 34 of 56
1,426 Views
Message 34 of 56

Re: Proximity sensor issue during call

I contacted support and had the same old generic email, re boot phone, clean sensor etc. I did tell them to look at forum to see other people getting same problem. They didn't respond to it. Looks like we are stuck with it.. 

Adviser
Message 35 of 56
1,421 Views
Message 35 of 56

Re: Proximity sensor issue during call

Sony, you suckers!

 

P.S. Let's check if you read the forum.

Inhabitant
Message 36 of 56
1,413 Views
Message 36 of 56

Re: Proximity sensor issue during call

Are there Mods on here or what? 

One time poster
Message 37 of 56
1,334 Views
Message 37 of 56

Re: Proximity sensor issue during call

Same issue here...

Apprentice
Message 38 of 56
1,309 Views
Message 38 of 56

Re: Proximity sensor issue during call

Make sure you do this: When you call/recive a call don't turn off the display with the power button. Move you phone close to the ear in a way that the proximity sensor get very close to the upper part of the ear. The sensor can read only for a 1 or 2 cm, not more.

 

Someting similar was happening to my older Xperia M2 and sometimes to the XA2.

 

Just be carefull how you put it at your ear.

One time poster
Message 39 of 56
1,183 Views
Message 39 of 56

Re: Proximity sensor issue during call

I'm also having issues with proximity sensor. Calls are getting muted, have to tap mute/unmute during calls. Also pressing keys with my cheek during calls.

This is failing to be a phone, can be used for other purposes though.

Inhabitant
Message 40 of 56
1,145 Views
Message 40 of 56

Re: Proximity sensor issue during call

I have the same problem, this problem is software or hardware?

 

The fist 10/15 seconds its all alright, and in next is on/off the screen

 

Plz sony, fix this..