account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

XA2 Ultra Wifi calling missing?

One time poster
Message 1 of 7
2,584 Views
Message 1 of 7

XA2 Ultra Wifi calling missing?

Hi, I just switched from T-Mobile to AT&T and I know T-Mobile did not support wifi calling on unlocked phones, but AT&T says they do and they said they have it turned on, and everything on Sony's support pages says that I should have it, but the option to turn it on is nowhere in the phone app settings or the Android system settings. 

 

This is a problem in both Oreo and the Pie ota update I got last night. 

 

Is there any fix for having the option to show up? I really need it where I just moved to and if I can't get it working I'll have to get a different phone and I'm really liking this Xa2 ultra and hope it's something that can be fixed.

6 REPLIES 6
Emperor
Message 2 of 7
2,571 Views
Message 2 of 7

Re: XA2 Ultra Wifi calling missing?

@goody2toad 

 

What AT&T told you it's not quite 100% accurate, WiFi calling will work with certain unlocked phones, usually iPhones 

 

https://www.cnet.com/news/what-is-wifi-calling-tmobile-verizon-att-google-fi-sprint-setup-faq/




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Enthusiast
Message 3 of 7
2,552 Views
Message 3 of 7

Re: XA2 Ultra Wifi calling missing?

Mine supports WiFi calling and I have T-Mobile service so you must be mistaken somehow.

Visitor
Message 4 of 7
2,494 Views
Message 4 of 7

Re: XA2 Ultra Wifi calling missing?

On the most recent update to the Android (9.0) I didn't have wifi calling. Straight talk said it wasn't available with the AT&T Sim and would have to get a T-mobile sim. I did that and Straight talk says that everything is setup on there end yet I see no 'option' anywhere to turn it on. Can anyone help?

Highlighted
Enthusiast
Message 5 of 7
2,488 Views
Message 5 of 7

Re: XA2 Ultra Wifi calling missing?

Well, obviously you are doing it wrong. In order to access WiFi Calling, you need to switch over to WIfI ON YOUR PHONE FIRST in order to use that feature. Simply go to your settings, Network & Internet, turn on WiFi, and scan your homes wireless connection. Once that's done you may call that way! If by some chance this has already been established and you still cannot make calls, well that's a whole other mystery on your part.

Visitor
Message 6 of 7
2,485 Views
Message 6 of 7

Re: XA2 Ultra Wifi calling missing?

Wow HRJ! Great comment! Thank you for your help on nothing whatsoever. So yes wifi was enabled and to test it, I even placed the phone onto airplane mode followed by turning wifi back on.  I have searched the option menu's yet nothing has come to fruition. Does anyone have any menu path on the v9.0 where they are typically seeing an area to turn wifi calling on? 

One time poster
Message 7 of 7
2,404 Views
Message 7 of 7

Re: XA2 Ultra Wifi calling missing?

How do I apply wifi calling?