account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

Rear camera

SOLVED
Rookie
Message 1 of 8
1,446 Views
Message 1 of 8

Rear camera

Does anyone know why my rear camera is not working?

The front one is working fine. 

Need some help please? 

1 ACCEPTED SOLUTION

Accepted Solutions
Sony Xperia Support
Message 2 of 8
1,441 Views
Message 2 of 8

Re: Rear camera

Hi @Marce01, I am sorry to hear about this.

 

Do you receive any kind of error message from the camera app while trying to use the main camera or is the display just black?

 

Firstly i would suggest that you try clearing data for the camera app in order to reset all settings for the camera app. In order to do this, find and tap Settings > Apps and notifications > App-info/Show all XX apps > Camera > Storage > Clear data > Tap "OK" > Restart the phone. Your previously taken photos will not be affected by this measure.

 

Another good idea is to try to reboot your phone in safe mode and see if the main camera works while in safe mode. All apps downloaded from play store is temporarily disabled while in safe mode and by doing this you can see whether this is caused by a downloaded app. For more information on safe mode and how to use it, click here.

 

If none of these measures manages to improve the functionality of the main camera I suggest that you try to perform a software repair using a computer and Xperia Companion. Please note though that a software repair will erase all user data, so remember to do a backup of your user data first in order to prevent data loss.

 

Try these measures and let me know how it goes! Slightly smiling Face 


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

7 REPLIES 7
Sony Xperia Support
Message 2 of 8
1,442 Views
Message 2 of 8

Re: Rear camera

Hi @Marce01, I am sorry to hear about this.

 

Do you receive any kind of error message from the camera app while trying to use the main camera or is the display just black?

 

Firstly i would suggest that you try clearing data for the camera app in order to reset all settings for the camera app. In order to do this, find and tap Settings > Apps and notifications > App-info/Show all XX apps > Camera > Storage > Clear data > Tap "OK" > Restart the phone. Your previously taken photos will not be affected by this measure.

 

Another good idea is to try to reboot your phone in safe mode and see if the main camera works while in safe mode. All apps downloaded from play store is temporarily disabled while in safe mode and by doing this you can see whether this is caused by a downloaded app. For more information on safe mode and how to use it, click here.

 

If none of these measures manages to improve the functionality of the main camera I suggest that you try to perform a software repair using a computer and Xperia Companion. Please note though that a software repair will erase all user data, so remember to do a backup of your user data first in order to prevent data loss.

 

Try these measures and let me know how it goes! Slightly smiling Face 


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Rookie
Message 3 of 8
1,433 Views
Message 3 of 8

Re: Rear camera

Hello Martin. 

Really Thank You for your tips. 

I tried The first one with clearing data and it works. Thank you so much for your help 🤗🤗🤗

Sony Xperia Support
Message 4 of 8
1,428 Views
Message 4 of 8

Re: Rear camera

Thank you @Marce01 for your quick reply!

 

I am delighted to hear that you managed to resolve it so easily! Feel free to return if you have any other questions regarding your phone! Slightly smiling Face


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Learner
Message 5 of 8
602 Views
Message 5 of 8

Re: Rear camera

I also have same problem please also tell me when you solve the problem 

Sony Xperia Support
Message 6 of 8
599 Views
Message 6 of 8

Re: Rear camera

Hi @WaqasMalik, sorry to hear about that.

 

Have you been able to try any of the troubleshooting that i mentioned in my previous post?


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Learner
Message 7 of 8
591 Views
Message 7 of 8

Re: Rear camera

No I didn't see any previous post. Please guide I am so upset about that fault

Highlighted
Sony Xperia Support
Message 8 of 8
569 Views
Message 8 of 8

Re: Rear camera

I see, @WaqasMalik.

 

Do you receive any kind of error message from the camera app while trying to use the main camera or is the display just black?

 

Firstly i would suggest that you try clearing data for the camera app in order to reset all settings for the camera app. In order to do this, find and tap Settings > Apps and notifications > App-info/Show all XX apps > Camera > Storage > Clear data > Tap "OK" > Restart the phone. Your previously taken photos will not be affected by this measure.

 

Another good idea is to try to reboot your phone in safe mode and see if the main camera works while in safe mode. All apps downloaded from play store is temporarily disabled while in safe mode and by doing this you can see whether this is caused by a downloaded app. For more information on safe mode and how to use it, click here.

 

If none of these measures manages to improve the functionality of the main camera I suggest that you try to perform a software repair using a computer and Xperia Companion. Please note though that a software repair will erase all user data, so remember to do a backup of your user data first in order to prevent data loss.

 

Try these measures and let me know how it goes!


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.