account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

[Xperia] Problems with PC connection for 2.1 update

Highlighted
Visitor
Message 1 of 3
1,258 Views
Message 1 of 3

[Xperia] Problems with PC connection for 2.1 update

Hey guys,

The Xperia has finally upgraded to 2.1, however I am having a world of problems actually getting the flash update installed.

My problem is that while running the Sony update software, it asks me to turn off the phone, hold the back button, and connect the USB cable. I do this, and absolutely nothing happens. If I release the back button, the phone boots up.

Every so often, I get a popup from Windows asking me that it has detected a new device and wants to install drivers for SEMC USB Flash. I've tried automatic installations, and none of the manual drivers I'm tracking down are working either ("Driver not intended for this platform"). 

Sony help was an absolute joke. I was told to "restart my PC, or restart the phone/update service." When I explained that it didnt work, I was told, "Well, it should." His manager told me the exact same thing and suggested it was a problem with the USB cable, however I know this isn't true as I'm able to connect the phone to my PC for data transfers/charging.

I'm at my wits end, does anyone know what's wrong?

2 REPLIES 2
Emperor
Message 2 of 3
1,063 Views
Message 2 of 3

Re: [Xperia] Problems with PC connection for 2.1 update

@mikkynoah 

 

Have you install and uninstall XC? 

 

Also update JAVA and it'll be wise to test a different USB cable and usb port




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Learner
Message 3 of 3
1,046 Views
Message 3 of 3

Re: [Xperia] Problems with PC connection for 2.1 update

Maybe it's because your XA2 plus is recognized as a Lenovo LINK in Device Manager. That happens on my PC. If I remove it (Lenovo Device Class -> Lenovo LINK) and re-connect my phone all works fine. But a few days later I have the same Lenovo LINK in my Device manager. I'll post a new message about this subject.

 

Bert alias LACOBO