account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Wifi Signal dropping on XA1

Adviser
Message 71 of 223
1,621 Views
Message 71 of 223

Re: Wifi Signal dropping on XA1

I called Sony support line here in Brazil and they tell me to send my phone to technical support to be fixed, but I really doubt if they can do anything without use some Sony software patch.

 

And this patch not exists yet.

 

Go Sony.

Learner
Message 72 of 223
1,617 Views
Message 72 of 223

Re: Wifi Signal dropping on XA1

Vi que terei que fazer isso mesmo. Obrigada!

 

Learner
Message 73 of 223
1,581 Views
Message 73 of 223

Re: Wifi Signal dropping on XA1

Whether you are using 2.4ghz or 5ghz, you experience the same issues. I have tried this, even completely replacing my wireless router. After reading this forum, I tried shutting off Bluetooth and the wifi works fine, but of course now I can't connect to any Bluetooth devices... So yes, still an issue. 

Highlighted
Adviser
Message 74 of 223
1,553 Views
Message 74 of 223

Re: Wifi Signal dropping on XA1

Mine is exactly the same. It happens on all WiFi not just at home. Once you get the authentication problem the only way to get it to work is to restart it. Very, very poor from Sony. 

 

Learner
Message 75 of 223
1,545 Views
Message 75 of 223

Re: Wifi Signal dropping on XA1

Turning off the Bluetooth is a terrible option if you regularly wear a smartwatch, or you know, use Bluetooth.

 

This happens to me as well on all 5 WiFi networks I use. No other devices have a problem on any of them.

 

Hopefully Sony addresses this or Oreo hits the XA1 and fixes this. WiFi and Bluetooth are core functionalities.

One time poster
Message 76 of 223
1,525 Views
Message 76 of 223

Re: Wifi Signal dropping on XA1

Chiming in as well. When I first got the phone back in August, it worked fine.

 

The wifi issue started cropping up in late October or early November.

 

I do tech support for a living, and have tried everything listed in this forum (switching airplane mode, trying different routers, even changing security type on them, rebooting, assigning a static IP etc).

 

The only DEPENDABLE "solution" is to turn off Bluetooth. This is unacceptable.

 

There needs to be a software update to fix this.

Apprentice
Message 77 of 223
1,491 Views
Message 77 of 223

Re: Wifi Signal dropping on XA1

I have worked out that the WiFi works as long as Bluetooth is switched off and visa versa. It explains why toggling airplane mode helps. Unfortunately Sony are not offering any solutions for a permanent software fix. So while this is not the optimum solution it works for now, especially if you can't exchange you new phone.

Needless to say I will not buy a Sony phone again due to lack of response even with so many customers reporting the same fault.

Adviser
Message 78 of 223
1,474 Views
Message 78 of 223

Re: Wifi Signal dropping on XA1

I am not on Twitter but wondering if anyone had posted to Sony there. For some reason as soon as people start making problems super public and complaining about a company they are fairly swift with their response as bad publicity is not good. 

Anyone tried this and got a response as clearly we are getting no where posting here. 

Adviser
Message 79 of 223
1,334 Views
Message 79 of 223

Re: Wifi Signal dropping on XA1

No News, Sony?

 

We're waiting.

One time poster
Message 80 of 223
1,298 Views
Message 80 of 223

Re: Wifi Signal dropping on XA1

I have the same problem. Purchased the phone in June. Problems started recently. It is very aggravating.