account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

sony XA won't turn on but led is red when connect charger

One time poster
Message 41 of 46
783 Views
Message 41 of 46

Re: sony XA won't turn on but led is red when connect charger

I have the same problem. My Xperia XA Rosê is dead. The red led lights up when I put it in the charger, but it does not signal the life.

One time poster
Message 42 of 46
620 Views
Message 42 of 46

Re: sony XA won't turn on but led is red when connect charger

The problem is in the back cover. Try to hold press the back cover and then hard reset the phone by press power button plus volume +, then start the phone. But never relese the pressure on the back cover. 

One time poster
Message 43 of 46
366 Views
Message 43 of 46

Re: sony XA won't turn on but led is red when connect charger

sony this is a terrible phone..all sorts of hardware issues and the restart is only a temp fix.in my case the phone keeps turning on and off when charging..stick to tv and mini disc

Visitor
Message 44 of 46
352 Views
Message 44 of 46

Re: sony XA won't turn on but led is red when connect charger

Hey!

 

I tried the suggestion of applying pressure on the back. As stupid as people may think it is, at least my phone "attempts" to boot (I get the 1 vibration, then 3 fast ones) but the screen is blank.

Still better than having no response.

This leads me to believe that my phone may have a physical issue affecting it? I just took it off its case to clean it when it starting freezing and services were crashing so I did a full reset.

The phone went thru the setup, no problem. But right when it was time to finish setup the phone crashed and it restarted into the "powered by Android" screen. Then the Xperia logo would half- show before it froze. Then I tried to reboot by pressing vol+ + power...and nothing happened for the past hour. Same symptom: my phone was at 92% or so when the problem started, but now getting the red battery charging LED. I used to love my Xperia Z3 but my wife bent it and now I switched to this phone that is poor quality if I have to "press the back" to have a reaction of sorts. What in the heck, right?

Visitor
Message 45 of 46
351 Views
Message 45 of 46

Re: sony XA won't turn on but led is red when connect charger

Again, it worked. I found a sweet spot right around the area where the phone and the micro USB connects. Phone is back on and still some applications are crashing but this is some sort of crazy hardware/software issue.

Highlighted
One time poster
Message 46 of 46
152 Views
Message 46 of 46

Re: sony XA won't turn on but led is red when connect charger

thanks