account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

WiFi issue after 7.0 update

One time poster
Message 1 of 15
2,023 Views
Message 1 of 15

WiFi issue after 7.0 update

Since doing the update,  every time I try to connect to a different WiFi network I'm having to restart my phone. When I'm connected to one it keeps dropping connection. Is there any way to fix this. I don't have much mobile data to use as I've always used WiFi. 

14 REPLIES 14
One time poster
Message 2 of 15
2,007 Views
Message 2 of 15

Re: WiFi issue after 7.0 update

Same issue here.... Updated on Friday and Wi-Fi has been dodgy ever since. Will connect for a little while and then drop off and not reconnect without restarting the phone. 

One time poster
Message 3 of 15
1,974 Views
Message 3 of 15

Re: WiFi issue after 7.0 update

Hi Folks 

The same here and having issues with WhatsApp, Outlook and FB not updating until WiFi is switched off. A reboot sorts it temporarily but then starts behaving the same again. 

Emperor
Message 4 of 15
1,972 Views
Message 4 of 15

Re: WiFi issue after 7.0 update

@Morgs

 

test the phone on >>> safe mode for few hours, see if you encounter the same issue




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Learner
Message 5 of 15
1,941 Views
Message 5 of 15

Re: WiFi issue after 7.0 update

Same here since the update my wifi on this device only is constantly dropping internet service but still connected to the router /modem. All other wifi devices work great. So hey SONY some one has purposely wrote a severe bug in order for you to hire them again. You should find the coder and sue for product sabotage. 

Visitor
Message 6 of 15
1,929 Views
Message 6 of 15

Re: WiFi issue after 7.0 update

Do they plan to have some fix in this 7.0 ? But i cant do an update without wifi....

Learner
Message 7 of 15
1,840 Views
Message 7 of 15

Re: WiFi issue after 7.0 update

Oh and it's happening on the 5G only for me. Seems every time when the phone goes to sleep it drops wifi. I have no power save settings on. When im connected to regular wifi it work proper. 

Highlighted
Visitor
Message 8 of 15
1,806 Views
Message 8 of 15

Re: WiFi issue after 7.0 update

I have the same problem too.  after updating I got so many problems with my phone. I wish I didn't do update. 

Is Sony In hibernation? 

One time poster
Message 9 of 15
1,747 Views
Message 9 of 15

Re: WiFi issue after 7.0 update

No regret, no remorse.

 

1. Start "Xperia Companion" software.

 

2. Click "software reparation" or similar (I am translating from spanish). It is the second option.

 

3. Once reparation has finished, choose option "start from scratch" or similar. Do not choose recover the information from Google.

 

It worked for me. Recovering your Apps afterwards won't take you more than half an hour.

One time poster
Message 10 of 15
1,618 Views
Message 10 of 15

Re: WiFi issue after 7.0 update

Turning off Bluetooth does the trick here, than it keeps on, waiting for a fix