account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

Constant loss of signal πŸ“Ά

SOLVED
Message 1 of 25
8,851 Views
Message 1 of 25

Constant loss of signal πŸ“Ά

My phone won't stay connected to my service provider.
It jumps from full signal to no signal all day it Dosent matter where I am. Is this an on going issue with this phone or am I the only one.
1 ACCEPTED SOLUTION

Accepted Solutions
Sony Xperia Support
Message 8 of 25
13,205 Views
Message 8 of 25

Re: Constant loss of signal πŸ“Ά

Ah, this must have been a 2G network, it is likely that network carrier has stopped their 2G transmission which the handset could have been set to by default, although it should not be.

 

Sorry we did not go over this section, but I am glad you managed to resolve the issue Slightly smiling Face


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

24 REPLIES 24
Sony Xperia Support
Message 2 of 25
8,845 Views
Message 2 of 25

Re: Constant loss of signal πŸ“Ά

Hi @Redskyatnight,

 

Welcome to the community,

 

I am sorry to hear about this. This could be due to a few things, are you running any type of battery performance or antivirus on the device?

 

These types of apps in some cases can cause issues with network signal.

 

Please let me know.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Message 3 of 25
8,843 Views
Message 3 of 25

Re: Constant loss of signal πŸ“Ά

No the phone isn't a month old. I haven't added anything like that. I was warned by my service provider thar their were a lot of complaints about the phone but they were about the battery and or the camera.

Sony Xperia Support
Message 4 of 25
8,841 Views
Message 4 of 25

Re: Constant loss of signal πŸ“Ά

I see, have you tried using another SIM card to test out the signal strength, although the SIM may work on another device without issue, this does not mean it will work in this device correctly.

 

I am sorry for this inconvenience.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Highlighted
One time poster
Message 5 of 25
8,777 Views
Message 5 of 25

Re: Constant loss of signal πŸ“Ά

I have the same problem with my phone plus I have a weird battery bug which goes from full to one percent in mins
Message 6 of 25
8,773 Views
Message 6 of 25

Re: Constant loss of signal πŸ“Ά

I'll try the new Sim card idea. I love the phone other than the signal issue.

Message 7 of 25
8,740 Views
Message 7 of 25

Re: Constant loss of signal πŸ“Ά

I went to my service provider and and talked to them about the Sim card solution. . They had a better idea instead of costing money their is a setting for the signal in the phone that they neglected to change when I purchased the phone. They did that within minutes phone was in hand costing no money and it's working strong. . For freedom mobile the phone in its out of the box state conflicts with their service. . It's changed no new Sim card and the phone works as it should. . I'm happy with my Sony.
Sony Xperia Support
Message 8 of 25
13,206 Views
Message 8 of 25

Re: Constant loss of signal πŸ“Ά

Ah, this must have been a 2G network, it is likely that network carrier has stopped their 2G transmission which the handset could have been set to by default, although it should not be.

 

Sorry we did not go over this section, but I am glad you managed to resolve the issue Slightly smiling Face


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

One time poster
Message 9 of 25
8,702 Views
Message 9 of 25

Re: Constant loss of signal πŸ“Ά

I have somewhat same problem with my xa ultra. It looses signal but it's ok. but it cant change network autmatically from LTE to WCDMA or GSM. I cant make calls as my network provider AirTel does not support VoLTE.Please fix it. 

Regular
Message 10 of 25
8,199 Views
Message 10 of 25

Re: Constant loss of signal πŸ“Ά

had the same problem had my first phone replaced with a new one by my network carrier. had a new unit and the problem still there i called their support tech and told me to put my mobile network to LTE only which makes my mobile data stable the problem is while on LTE only i can't call or text. i think this is a software problem i see other user have this problem and i see this problem only on single sim variants please fix this the phone is very good it's just sad it have a major bug